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About This Guide
This user guide is intended to supplement Find it EZwebsite resources (FAQ, Knowledge Base, Video Tutorials, and Corporate
Documents) byproviding step-by-step procedures to help youmake themost of your Find it EZ product.

If we can improve this reference in anyway, please feel free to send us your feedback. See "Send Feedback" on page 176.

Visit https://www.finditez.com/support/#overview for Find it EZwebsite resources.

This guide uses the following document conventions:

Programwindowsor dialog box titles are shown inBOLD

Programmenusare shown like this: File -->Open

Program buttonsare shown like this: <Cancel->

Keyboard keysare shown like this: [Enter]

Note: This is a note.

Tip: This is a tip.

Alert: This is an alert.

Example: This is an example.

See Also:
• This is a cross-reference

• "Get Started" on page 31

This is a hyperlink: http://www.finditez.com/

About Find it EZ
Find it EZ Software Corp is a global leader in developing and delivering productivity improvement tools for software developers. Our
award winning software developer tools provide instant, comprehensive and pin-point accurate where-used results all in one place.
These productivity tools offer a new solution for crystal reports designers, database developers and software vendors to better man-
age release changes through every phase, frommore accurate estimating, to optimal design selection, rapid development,
improved code quality for smoother end-user roll out and expedited critical production support.

Tools developed byFind it EZ Software Corp support allmajor programming languages, reports and databasesacrossan entire n-
tier enterprise application with a single integrated package.

Productivity software toolswith vendor certified support to search and document CrystalReports, SSRS, Oracle Reports, SQL
Server, Oracle, MySQL,MSAccess, DB2, Cloud databasesSQL Azure and Amazon RDS, Excel plusmore for complete change
impact analysis. Database developers can take advantage of a full software stack impact analysis tool that identifies all interrelated
componentswhenever changesare planned or made in an underlying database.

Byusing our productivity software products, software developers benefit from:

https://www.finditez.com/support/#overview
http://www.finditez.com/
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• Saving time andmoneybyquickly searching allCrystalReports, application source code, and/or databaseswith just one
integrated software tool.

• More accurate and efficient source code changemanagement.

• Ability to determine the exact scope and impact of planned changes.

• Easily estimate the time required to complete a change and ensure better quality code releases.

• Effective RiskManagement, ResourceManagement and Cost Management.
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Installation, Activation, and Updates
This section describes the steps required to download, register, install, configure, update, andmanage your Find it EZ license and to
understand the benefits and limitationsof product trials.

Download Find it EZ
1. Visit https://www.finditez.com/.
2. Select the product that you want to download. Refer to the following documents to select the product that best meets your

needs:

a. https://www.finditez.com/resellers/salesaids/FinditEZ_compare_editions.pdf

b. https://www.finditez.com/resellers/salesaids/Product%20Selection.pdf
3. Click on the desired product edition tab.

4. Click on the correspondingDownload Now! button. You will be directed to themember log in area.
5. If you have not done so already, register for a free Find it EZ account. See: "MyAccount" on page 163.

6. Once logged in, you will be directed to theSoftware Downloads tab.

See Also: 
• "Download Release Version" on page 166

View or Edit Proxy Settings
1. From the Find it EZ menu, select Tools -> Proxy Settings. TheProxy Settings dialog boxwill appear, as below:

https://www.finditez.com/
https://www.finditez.com/resellers/salesaids/FinditEZ_compare_editions.pdf
https://www.finditez.com/resellers/salesaids/Product Selection.pdf
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2. Choose and/or enter proxy settings, as required.

Note: If you don't know your proxy settings, please contact your NetworkAdministrator.

3. To save your changesand close theProxy Settings dialog box, click on theOK button.

Download Connectors
Source items that require a connector will appear with a smallwarning icon preceding the name. See example below:

Note: Some connectors are required (e.g. '.net') but others are optional (depending on whether or not you want to search a par-
ticular document type that then needsa corresponding vendor supplied connector). After product install on first run configuration
wizard for setting up your environment, if you select one or more source items that require connectors, the wizard will prompt you
to auto-download and install them. If you do not do so, or later add a source item, you will note that it hasa yellow alert triangle icon
next to it in the left (Source) panel. If you attempt to include such a source item in a project, you will be prompted to auto download
and install the required connector.

Click on the source item/warning to download the associated connector.

If you try to initiate a search that includesa selected source lacking a required connector, an error message will be generated. See
example below:

From the Program:

Note: Downloading and installing a connector will require local administrative rights on your system.
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1. From the Find it EZ menu, select Tools -> Download Connectors -> [Connector Name]. ADownload Connector
dialog will appear.

2. Where applicable, click on theProxy Settings button. AProxy Settings dialog will appear.

a. Enter your proxy credentials for the selected connector.

Note: If you don't know your proxy credentials, please contact your network administrator.

b. When settingsare complete, click on theOK button to save.
3. Click on theDownload & Install button. The connector will begin downloading.

a. Once downloaded, a Find it EZ InstallShield Wizard will appear.
b. Click on theNext button.
c. Read and follow the instructionsprovided.

d. When complete, click on the Finish button.

On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSoftware Downloads tab. A list of product releasesand optional connectorswill appear.
3. Locate the product release for which you want to download a connector.

4. In theDownload Optional Connectors section of the table, click on the corresponding version number in the desired con-
nector name column. AConnector Details dialog boxwill appear.

5. To download the selected version from the Find it EZ server, click on theDownload Nowbutton. OR,

6. Where applicable, to download the selected version directly fromMicrosoft (i.e. Access), click on the directly from
Microsoft link or directly from SAP (i.e. CrystalReports), click on the directly from SAP link.

7. The connector will begin downloading.

a. Once downloaded, a Find it EZ InstallShield Wizard will appear.
b. Click on the Next button.
c. Read and follow the instructionsprovided.

d. When complete, click on the Finish button.

8. To close theConnector Details dialog box, click on theClose or X button.

See Also:
• "SAPRepositories - Compatibility Table" on page 169

Installation and Configuration Wizard
After you download and install Find it EZ and run it for the first time, aConfiguration Wizard opens to walk you through the initial
setup and configuration process.

Click on theNext >>button to continue, and follow the instructions.



First Run ConfigurationWizard

6 © 2010 - 2016 Find it EZ Software Corp

First Run ConfigurationWizard

1. If you use a SAPBOEor Crystal Server for scheduling report delivery, select a version from theSAP Repository drop-
down list.

2. If you use one or more of the supported repositories, click to checkall those that apply.

3. Click on theNext >button to continue.
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To create and apply a custom template:

1. Click on theMy Projects template button. See note below:

Note: Clicking on theMy Projects template button will reset (i.e. check) only the source itemsyou have included across
all of your previously saved Find it EZ projects. If this is the VERY first time you are installing Find it EZ, thiswill blankout
(i.e. uncheck) everything. Then, youmust select only those itemsyou have installed and would use Find it EZ to search.
In addition, when you install an upgrade that addsnew source items, these are also 'checked' initially to highlight new
items.

2. Scroll down to view itemsand click to checkor un-check source items, asdesired.

3. Click on theOK button to save.

To clear all individual items:

1. Click on theNone template button. All individual source itemswill be un-checked.
2. Click to checkat least one source item.

3. Click on theOK button to save.

To select, modify, and apply an existing template:

1. Click on the desired template button. Note that applicable itemsare selected in the list.

2. Scroll down to review the items included in the selected template.

3. Click to checkor un-check individual items in the template, as desired.

4. Click on theOK button to save.

To discard any changes, click on theCancel button.
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Index Reset on Upgrades
After upgrading to a newer version of the application where there is an a index structure change or model change, you will see the fol-
lowingmessage:

In these circumstances, the indexneeded to be cleared in order to make the new information available.

To clear thismessage, click on theOK button.

See Also: 
• "Download Find it EZ" on page 3

• "ConfigurationWizard" on page 29

License Manager
Licensemanager is a product license authorization checkon start-up (e.g. a trial period or SaaS annual renewal period check to see
if it is valid before running the program). The licensemanager has to be running (asaWindowsService).

Note: The licensemanager runswithin (behind) the firewall so is secure and USHealth Insurance Portability&AccountabilityAct
(HIPAA) compliant.

During install, a warning that it is going to be listening on a TCP/IP port maybe issued byWindowsduring setup. If the service does
not start (by default), you will receive an "Unable to connect to the licensemanager..." message preventing the program from run-
ning.

Solutions for Pro Desktop and DevSurge 365 are:

1. Click on theYes button on themessage to try restarting the service.

2. Reboot your machine.

3. Download and/or re-install the software.

4. If none of the above work, contact your local technical support or contact Find it EZ support and provide log files.

See Also:
• "Find it EZ Support" on page 162

Activate License
To activate your license:

1. Once the product is downloaded and installed, launch the program. TheActivate dialog boxwill appear.
2. Enter your accountEmail Address, First/Last Name, and productSerial Number.
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3. Click on theActivate button. If successful, the programwill be activated for use.

Note: If you receive an error message (e.g. "Entered information is incorrect. Please check the serial number and try
again"), try again. Ensure there are no extra characters or spaces in the serial number. If you feel you are receiving this
message in error and continue to experience difficulty attempting to activate your product, please contact sup-
port@finditez.com .

See Also:
• "Enter New SerialNumber" on page 171

• "Download Find it EZ" on page 3

• "Download Release Version" on page 166

• "Get a New Trial License" on page 171

Activate LicenseManually
If you have a corporate security policy that doesnot allow the workstation on which you are installing Find it EZ to be connected dir-
ectly to the Internet, usemanual activation.

This is quite common in large corporationswhere outbound internet connectionsare locked down (on certain ports) or not available
to go to a given website domain, etc. For example, our automated activation system is a web service on domain activ-
ation.finditez.com . A corporate security policymayprevent an application from attempting to "call out," or maynot allow a connection
to this specific domain name. However, they could often still use a web browser to go to our website onwww.finditez.comas the
policy typically allows this normal internet accessactivity.

In caseswhere no Internet access is allowed even from aweb browser, the end user would have to find a workstation (home com-
puter other office computer that is permitted web browsing) fromwhere they can perform themanual activation by sending the long
codesbackand forth between computers aswithin an email for example.

Note:Manually activated licensesexpire in the lesser of 30 days from now or the original expiry date. Once expired, manual activ-
ation will be required again.

From the Program:

1. Once the product is downloaded and installed, launch the program. TheActivate dialog boxwill appear.

Note: You can also access theActivate dialog box from themenu; select Tools -> License Management -> Enter
New Serial Number.

2. Enter your accountEmail Address, First/Last Name, and productSerial Number.
3. Click on theManual Activation button. TheManual Activation dialog boxwill appear.
4. Follow the instructions in Step 2); copyand paste the information in the boxprovided by clicking on theCopy to Clipboard

button. Alternatively, download themanual activation request asa file by clicking on theSave to File button.
5. In Step 1), click on theOpen Website button.

a. Log in to themember website.

b. Click on theSerial Numbers tab.
c. Click on theManual Activation button. TheManual Activation dialog boxwill appear.
d. Paste your manual activation code in the boxprovided. Or, click on theChoose File button to load it from a file (if you

saved it in step 4 above).

e. Click on theNext button. A response file will be generated.
f. Copy the provided code or click on theDownload button to download the response file.
g. Return to the Find it EZ program.

mailto:support@finditez.com?subject=Activation Error
mailto:support@finditez.com?subject=Activation Error
http://www.finditez.com/


Product Trials and Limits

10 © 2010 - 2016 Find it EZ Software Corp

6. Paste the response from our website into the Step 3) boxprovided by clicking on thePaste from Clipboard button. Or,
click on the Load from File button to load the savedresponse file.

7. Once complete, click on theActivate button. The programwill be activated for use.

Product Trials and Limits
Product trails are subject to the following limitations:

• Time limited

• Feature (# of documents) capped

• Ability to create projects is restricted

• Number of trial licenses issued per customer capped (byunique companyemail domain)

All above get auto-reset whenever we release a newminor or major build. Release numbering is : major.minor.build. Customers can
request a new trialwhenever we announce / post a newmajor or minor release after their past trialwith an earlier version has
expired.

While in trial mode, creating projects is restricted:

• Code Search Pro (Desktop &Server): you cannot create anyadditional projects; just the single "Default" project is allowed.
This is required tomanage the # of documents (per project) trial limitation, see below.

• DevSurge 365: you can create only one additional (i.e. a maximum of 2) projects. This is required to permit easier eval-
uation of the "Compare" wizard (i.e. compare the default project to a "new" second project).

• The Default project can not be deleted. However, the one additional project permitted in a DevSurge 365 trial could be
deleted if desired to test this feature.

• Users also have full access to document filtering andmanaging their index so that they can bring in and check functionality
against various subsets of documents.

Number of licenses per customer:

• Equal to the number of registered login accounts linked to the customer account (+ 1 when the trial key is requested).

• A customer (user) can request a trial for each product edition. Theyare separate, unique keysand trials.

• We can, at our discretion, grant extensionsor additional trial licensesupon request.

• Feature limits are indicated in the table below.

Per project limits in trial mode:

Database Reports Source Code Documents

Code Search Pro Desktop 250 50 150 25

Code Search Pro Server 500 100 300 50

DevSurge 365 Enterprise* 500 100 300 50

*multiply by2 for total document limits asup to 2 projects are permitted.

Also note that in fully unlockedmode, DevSurge 365 allowsunlimited documents, while the Code Search Pro editionshave limits
(per project) but an unlimited number of projects in all product editionsare possible. This simplymakes it less convenient to use the
Code Search Pro edition if you havemore documents tomanage than is permitted per project as you have to filter the project doc-
uments and repeat each search (byproject) rather than using DevSurge 365 that can do it all in a single pass (unlimited documents
per project):

Per project limits in fully unlocked mode (all products allow unlimited # of projects):
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Database Reports Source Code Documents

Code Search Pro Desktop 5000 1000 3000 500

Code Search Pro Server 5000 1000 3000 500

DevSurge 365 Enterprise* unlimited unlimited unlimited unlimited

The product trial time limits are:

• Code Search Pro Desktop: 15 days

• Code Search Pro Server: 30 days

• DevSurge 365 Enterprise: 30 days

Check for Updates
From the Program:

1. From the Find it EZ menu, selectHelp -> Check for Updates.
2. If not updatesare available, you will receive amessage that reads "No updatesavailable at this time." To close thismessage,

click on theOK button.

3. If updatesare available, anUpdate Available pop-up will appear as in the example below:

4. Use the vertical scroll bar to view all release notes.

5. To access your Find it EZ account, click on theVisit Website button. Your account will open to theSoftware Downloads
tab.

6. To download and install the update, click on theDownload & Install button. ADownload Update pop-up will appear.
a. To enter proxy settings, click on theProxy Settings button.
b. To download and install the update, click on theDownload & Install button. The download will begin.

i. Once completed, the InstallShield Wizard will appear to walk you through the installation process.
ii. Follow the screen instructionsand click on theNext button to proceed through the steps.

Via Email from Find it EZ Software Corp:

All users on an active software assurance plan will receive email notification of new (optional / recommended / required) upgrades,
releases, updates, patches, and offers.

Note: If your support plan has lapsed or you have not yet decided, youmay request a free trial key to see what's new.
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Product Overview
This section providesan introduction to Find it EZ user interface layout, navigationmethods, customization options, and Filemenu
options.

User Interface Layout
Refer to the image and table below for a description of the key components of the Find it EZuser interface:

# Name Description

Menu Click on amenu item to view and navigate projects and settings, initiate a task, export or print
results, accessuser options, reports, help, andmore.

Search Quickly initiate a search using the "SearchWizard" on page 31. Or, "Perform aRegular
Search" on page 60, or "Use the Expression Builder" on page 65.

Source This panel allows you to select and configure settings for the source files (File Locations, Data-
bases, Report Utilities, Programming Languages, and Documents) within which you want to
search. Show or hide the panel byusing the and buttons. Expand or collapse a

source category byusing the or buttons (note that a category cannot be collapsed if an

item hasbeen selected). In the desired category, click to check the desired source items. To
select all items in a category, click to check the uppermost check-box located in the category
header.
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# Name Description

Options Show or hide the panel byusing the and buttons. Click to choose aSearch Type or

Scope option and click to check the desired Filters to apply to the search.

Results Once a search is complete, results can be viewed or edited via thiswindow. Select a tab to
viewResults,Statistics, andErrors. See "WorkWith Search Results" on page 97 for
details.

Details When a result is selected in theResultswindow, detailswill appear in thiswindow. See "View
Search Result Details" on page 101 for more information.

Navigation
Search navigation in Find it EZ is accomplished in twomain ways:

1. Byusing theSearch Wizard (for new users).

Note:Manyof the items included in theSearch Wizard can also be accessed via themenu. Refer to the table below.

2. Byperforming aRegular Search from themain screen (for intermediate or advanced users).

Search Navigation

# Search Wizard Option Menu Navigation

1 Search for a specific database object, code snippet, or
a variable to find any references throughout all of my
source code (including within reports and databases)

See: "Perform aRegular Search" on page 60.

2 Compare database schema, reports or files for dif-
ferencesbetween versions

Compare -> Documents, Reports & Databases

3 Extract database objects (tables, stored procedures,
views, etc.) used inmy reports

Document -> Business Intelligence -> SQL Code Extract

4 Generate detailed content documentation for my
reports

Document -> Business Intelligence -> Report Definition

5 Extract all SQL code used inmy reports Document -> Business Intelligence -> Show SQL Queries

6 Create a database cross-reference for my reports Document -> Business Intelligence -> Database Cross-
Reference

7 List allmy reports, including printer and update inform-
ation

Document -> Business Intelligence -> Report Listing

8 List the schedule for my reports inside an SAPBOEor
Crystal Server repository

Document -> SAP BOE / Crystal Server -> Report Sched-
ules

9 List the security for my reports inside an SAPBOEor
Crystal Server repository

Document -> SAP BOE / Crystal Server -> Security List-
ing
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# Search Wizard Option Menu Navigation

10 List the schedule for my reports inside a SQL Server
Reporting Services (SSRS) database

Document -> SQL Reporting Services -> Report Sched-
ules

11 Replace CrystalReport data source connectionsor
qualified table names

Replace -> Crystal Reports -> Data source connections
or qualified table names

12 Replace the username, password, server or database
of myReports in an SAPBOEor Crystal Server repos-
itory

Replace -> Crystal Reports -> BOE BI Database logon
information

See Also:
• "Launch theWizards" on page 31

•

• "Use the Expression Builder" on page 65

Customize View
The view of themain Find it EZ screen can be customized as follows:

• To show or hide theSource orOptions panels, see "Product Overview" on page 12
• To expand or collapseSource items, see "Product Overview" on page 12
• To add or removeSource items, see "Set Source Items" on page 24
• To add or remove repositories, see "Set File Locations (Repositories)" on page 27

• To show or hideProject Settings each time you select a scan source item, see "Search Locationsand Source Settings" on
page 75

• To configure source category and source item viewer/editor, see "Viewer / Editor Settings" on page 28

• To customizeResults list columns, see "Show or Hide Result List Columns" on page 24

• To show theSearch Wizard on start-up, see "ShowWizardson Start-up" on page 34

See Also: 
• "Set User Options" on page 21

File Menu Options
This section describes the variousoptionsavailable via the Filemenu. Follow the steps to save or open saved search results, save
project settings, export or print search results, and to exit Find it EZ.

Save Search Results
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Save. ASave Search Results dialog boxwill appear.
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3. In theName text box, enter a descriptive name for the results.

Alert: Database table data search resultswill not be saved.

4. Click on theSave button.

Note: Once you save search results, every subsequent change to the search results elements are automatically re-
saved. Also, If any search results have annotationsor have beenmarked complete and you attempt the exit/close the pro-
gramwithout first saving your results, you will be prompted to save your search results, continue without saving, or keep
the program open.

Open Saved Search Results
1. From the Find it EZ menu, select File -> Open. AnOpen Search Results dialog boxwill appear.

2. From theSearch drop-down list, select the name of the saved search results.

Note:Once saved results are opened, all further changes to them are automatically saved (this is reset when you exit the
programOR if you run another search to replace the "SAVED / re-Opened" search results that you had been working
with. Also, when you open a previously saved search result, this also auto-switches to the saved Project settings. The
saved results listed include the following identifiers: Date, Time, [File] Name, Project Name, Search Type, and Search
text.

3. Click on theOpen button. The selected search resultswill appear in theResultswindow.

See Also:
• "Add or Edit Annotations" on page 105

• "Mark Item(s) Complete or Incomplete" on page 104

Save Project Settings
If you have only one project (the Default project) and can havemore than one project, you will be prompted to save your current set-
tingsasa New Project upon closing the program. Click on theOK button to save your settings.

See Also:
• "Product Trials and Limits" on page 10

Export Results
Follow these instructions to export search results/result details, MSProject tasks, or an error list.

Export Search Results
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Export -> Search Results List. ASelect the items to include pop-up will
appear.
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a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. ASave As dialog boxwill appear.

i. Navigate to the destination folder.

ii. Enter the desired File name.
iii. Click on theSave button.

c. ASave Complete pop-up will appear.

i. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

ii. To close theSave Complete pop-up, click on theClose button.
3. Exported search resultswill contain the following data columns:

• Source Location
• File Type
• Host Name
• File Path or Database
• Document Name
• Number ofMatches
• Annotations

Export Search Result Details
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. To export selected details only:

a. In theResultswindow, click on a result row. Detailswill appear in theDetailswindow.
3. From the Find it EZ menu, select File -> Export -> Search Results Detail. ASelect the items to include pop-up will

appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. ASave As dialog boxwill appear.

i. Navigate to the destination folder.

ii. Enter the desired File name.
iii. Click on theSave button.

c. ASave Complete pop-up will appear.

i. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

ii. To close theSave Complete pop-up, click on theClose button.
4. Exported search results detail will contain the following data columns:

• Source Location
• File Type
• Host Name
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• File Path or Database
• Document Name
• Section
• Search Terms Matched
• Matches Found
• Original Line

Export MS Project Tasks
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Export -> MS Project Tasks. ASelect the items to include pop-up will
appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. ASave As dialog boxwill appear.

i. Navigate to the destination folder.

ii. Enter the desired File name.
iii. Click on theSave button.

c. ASave Complete pop-up will appear.

i. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

ii. To close theSave Complete pop-up, click on theClose button.
3. Exported search resultswill contain the following data columns:

• Active - Yesor No
• Task_Mode - Auto Scheduled or ManuallyScheduled
• Task_Name - Search Source and Path
• Notes - Host and Path

Import Tasks to Microsoft Project
1. See "Export MSProject Tasks" above.

2. OpenMicrosoft Project.

3. From the Filemenu, selectNew.
4. On theNewpage, clickNew from Excel workbook.

5. In theOpen box, click the arrow next toXML Format, and pickExcel Workbook.

6. Locate and select the workbook you want to import, and clickOpen.

7. In the Import Wizard, clickNext to get started, and follow the steps to complete the import.
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Export Error List
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. If anyerrors are generated during the search, theErrors tab in theResultswindow will be selected automatically, the total
number of errorswill be shown on the tab label, and error detailswill be listed.

3. From the Find it EZ menu, select File -> Export -> Error List. ASave As dialog boxwill appear.
a. Navigate to the destination folder.

b. Enter the desired File name.
c. Click on theSave button.

4. ASave Complete pop-up will appear.

a. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

b. To close theSave Complete pop-up, click on theClose button.
5. The exported error list will contain the following data columns:

• Location
• Type
• Host
• File Path or Database
• Document
• Error
• Details

See Also:
• "WorkWith Search Results" on page 97

• "Viewer / Editor Settings" on page 28

• "Set User Options" on page 1

Print Results
Follow these instructions to print search results or search result details.

Print Search Results
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Print -> Search Results List. ASelect the items to include pop-up will
appear.
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a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. A report containing the selected resultswill open in a new browser window and a browser

Print dialog will be launched.
3. Select theDestination and configure print settings, asdesired.
4. Click on thePrint button. The report will be sent to the selected destination printer or file.
5. The generated report will contain the following data:

Header:

• Date Created
• Search Type
• Search Options
• Search Expression
• Search Locations

Columns:

• Source Location
• File Type
• Host Name
• FilePath or DB (Database)

• Object Name
• # Found (Matches)

Print Search Result Details
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Print -> Search Results Detail. ASelect the items to include pop-up will
appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. A report containing the selected resultswill open in a new browser window and a browser

Print dialog will be launched.
3. Select theDestination and configure print settings, asdesired.
4. Click on thePrint button. The report will be sent to the selected destination printer or file.
5. The generated report will contain the following data:

Report header:

• Date Created
• Search Type
• Search Options
• Search Expression
• Search Locations
• Search Category

Header for eachmatch found:
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• Source Location
• File Type
• Host Name
• Filepath or DB (Database)

• Object Name
• # Matches

See Also:
• "WorkWith Search Results" on page 97

Exit Find it EZ
1. From the Find it EZ menu, select File -> Exit.

OR

2. Click on theX button located in the upper, right corner of the screen.
3. The programwill close.

See Also:
• "Save Project Settings" on page 15
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Basic Settings andCustomization
This section describes the steps required to set user options, preferences, and settings for Find it EZ.

See Also:
• "Customize View" on page 14

Set User Options
1. From the Find it EZ menu, select Tools -> Customize -> User Options. TheUser Options dialog boxwill appear, as

below:

2. Choose, select, or enter settingsasdesired. Refer to the table below for details:
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User Option Description

Use application default search settings (Boolean, Entire
Document)

Choose this option to apply the Find it EZ default search set-
tings (i.e.Search Type =Boolean Search,Scope =Search
Entire Document) for the next search. OR, see next option...

Use last search settings Choose this option to apply the last-used search settings for
the next search.

ShowWizards Click to check this item if you want to launch theSearch Wiz-
ard each time you start up Find it EZ.

Showmewhen updatesare available Click to check this item to receive a notificationmessage when
you start up Find it EZ when anynew updatesare available for
download.

Run in reduced performancemode (Used for
troubleshooting)

This option can be used if/when you have limitedmemory
(RAM) on your computer and Find it EZ is freezing, crashing,
logging .net memory issues, or taking a VERY long time to com-
plete a search. The Find it EZ programwill process themax-
imum number of documents simultaneously using threads. By
dropping this to reduced performancemode, only a single doc-
ument is processed at a time, reducing stresson a systemwith
a limited amount of RAM. Default =Off ( for optimal per-
formance ).

Enable CrystalReport locked file pre-checks (Local or
network files only)

Allows the CrystalReports scanner to detect locked files dur-
ing indexing and, if a file is currently open or locked, to make a
temporary copyof the file before allowing CrystalReports to
open it. Note that this feature is disabled bydefault as it can
affect performance.

Warnme if files are larger than: ___MB When processingmanydocuments in a folder & sub-folders
(especially "text" type documents), this option will allow you to
skip individual large documents during the search process that
are found in a source folder; like error logs, etc. that maybe in
a file directory but do not need to be searched (as theywill
either return toomany false positivesOR will slow down pro-
cessing unnecessarily). This gives you an opportunity at
search run time to skip certain very large files youmaynot
have wanted to be scanned but were in the folder and had a
file type you do want to search other (smaller) documents for
matches. You can change this setting to customize for your
environment. Default = 4MB.

Automatically expand details Click to check this item to expand selected result details in the
Detailswindow when a result is selected in theResultswin-
dow. If un-checked, detailswill appear collapsed. Click on the
"+" to expand.
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User Option Description

Always view myexported report after saving Click to check this item if you want exported reports to open
immediately after saving.

See Also: "Viewer / Editor Settings" on page 28.

Limit the number of matchesper object to: ___ Use this limit when toomanymatchesare being returned in
each individual document and you really only care if one or
more "hits" are discovered. Thiswill improve Find it EZ per-
formance; once the limit of matchesper document is reached,
the search enginemoveson to the next document and logsa
"maximum hits reached" warning in the error log. Default =
1000.

Show project settingswhenever I select a source item Click to check this item to launch theProject Settings dialog
boxeach time you select (check) an item in theSource panel.
These settingsallow you to include/exclude the selected item,
configure and test connection settingsand select folders
(where applicable), apply filters, select the viewer/editor with
which to open results, set options, and add or remove file
extensions.

Show an alert when I try to remove one or more search
results

Click to check this item if you want a confirmationmessage to
appear (i.e. "Are you sure you want to remove this item from
the search results?" Yes/No) each time you right-click on a res-
ult in theResultswindow and selectRemove.

Show an alert before I attempt to search database data Everytime you are about to run a search that includesdata-
base table data, when this option is checked, an alert is dis-
played. Thiswarns you that the search timemaybe long,
depending on the size of the table. Find it EZ searches for
matches in every column (field) of every row in the table. For a
table with a significant number of text columnsand rows, this
can really affect the search performance and run time. Find it
EZ allows for searching database table data, but this is inten-
ded for small "system" tables that are used in a dynamic table-
driven software system. Such tables contain references to
screen names, report labels, or even code to perform actions.
This is also whywe have the user explicitly choose a small sub-
set of tables and do not offer a "search all tables" option. Basic-
ally, this reminds the user theyare about to search data and
gives them the option to cancel the search / disable data
searching before proceeding. At aminimum, it lets them know
why the search is taking awhile. Default =On (to warn the user
everytime theyare about to search table data). Note also that
database table data searching is "disabled" bydefault.
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User Option Description

Enable detailed error logging This option is used to help identify the file on which a search
maybe getting stuck. It is best if used in combination with
"reduced performancemode" enabled and will allow the sys-
tem to log search steps in the "session log" in greater detail.
This is often requested by tech support for sending in logsand
helpsexpedite problem resolution. Default =Off.

3. Click on theOK button to save your settings. TheUser Options dialog boxwill close.
4. To discard any changes, click on theCancel button.

Show or Hide Result List Columns
Note: Theremust be results listed in theResultswindow in order for the followingmenu option to be enabled for use. Column
namesshown in grey cannot be hidden.

1. From the Find it EZ menu, select Tools -> Customize -> Result List Columns. A list of column nameswill appear.
2. Click to show or hide columns, asdesired. See note above.

Set Source Items
Note: These itemsare also set via theConfiguration Wizard. Source itemsselected below will be reflected in both themain
application (Source panel) and all Find it EZ wizards. Each time Find it EZ addsa new supported technology like a new database,
reporting tool, or programming language, this new item is automatically "enabled" bydefault so that after upgrade, you see this
new source item is now available (you can, of course, "hide" the item later - using the dialog boxbelow - if it doesnot apply to you).

From the Find it EZ menu, select Tools -> Customize -> Source Items. TheSource Items dialog boxwill appear, as below:
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Note: Collapse (i.e. "-" buttons for each source category) are intentionally disabled so that any individual checked source items
are always visible.

To create and apply a custom template:

1. Click on theMy Projects template button. All source items in the list will be unchecked bydefault.

Note: For an initial install, the default for theMy Projects template = all itemsunchecked . However, if you have anypre-
viousproject documents saved in your index, when you click on theMy Projects template button, anyand all source type
documents stored in the indexwill be selected. In addition, whenever we push out a new release that addsnew source
items, these are also 'checked' initially to highlight new items.

2. Scroll down to view itemsand click to checkor un-check source items, asdesired.

3. Click on theOK button to save.

To clear all individual items:

1. Click on theNone template button. All individual source itemswill be un-checked.
2. Click to checkat least one source item.

3. Click on theOK button to save.

To select, modify, and apply an existing template:
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1. Click on the desired template button. Note that applicable itemsare selected in the list.

2. Scroll down to review the items included in the selected template.

3. Click to checkor un-check individual items in the template, as desired.

4. Click on theOK button to save.

To discard any changes, click on theCancel button.

Set File Locations (Repositories)
1. From the Find it EZ menu, select Tools -> Customize -> File Locations. The File Locations dialog boxwill appear, as

below:

2. If you use a SAPBOEor Crystal Server for scheduling report delivery, select a version from theSAP Repository drop-
down list.

3. If you use one or more of the supported repositories, click to checkall those that apply.

Alert: Changing these selectionsmay require Find it EZ to automatically install any required vendor connectors and/or to
restart the program.

4. Click on theOK button to save and close.

5. To discard any changes, click on theCancel button.
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See Also:
• "Download Connectors" on page 167

Viewer / Editor Settings
These settingsallow you to select the viewer / editor with which a source category or item opens.

Note: TheWindowsDefault Editor (referenced below) is set at theWindowsoperating system level by the end user when you
install a new program. Or, you can change the default editor settings inWindows7 viaStart -> Default Programs or inWindows
10 viaStart -> Settings -> System -> Default Apps.

1. From the Find it EZ menu, select Tools -> Customize -> Viewer/Editor Settings. TheConfigure Viewer/Editor Set-
tings dialog boxwill appear, as below:

2. In theCategory Default section:
a. For each category, choose one of the following viewer/editor options:

• Find it EZ Viewer
• Windows Default Editor
• Selected Application

b. IF Selected Application is chosen:
i. Click on the corresponding folder icon. AnOpen dialog boxwill appear.
ii. Navigate to the program application you want to use to open this type of file.

iii. Click on theOpen button.
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OR,

3. In theBy Source Itemsection:

a. For each source item, choose one of the following viewer/editor options:

• Category Default
• Find it EZ Viewer
• Windows Default Editor
• Selected Application

b. IfSelected Application is chosen:
i. Click on the corresponding folder icon. AnOpen dialog boxwill appear.
ii. Navigate to the program application you want to use to open this type of file.

iii. Click on theOpen button.
4. To set all source items to use theCategory Default viewer/editor settings, click on theUse default settings button.
5. To save any changesand close theConfigure Viewer/Editor Settings dialog box, click on theOK button.

6. To discard changesand keep it open, click on theCancel button.

Configuration Wizard
TheConfiguration Wizard walks you through the steps required to set up your Find it EZ program so that it best meets your busi-
nessneeds.

1. From the Find it EZ menu, select Tools -> Configuration Wizard. TheConfiguration Wizard will appear.
2. Click on theNext >>button to continue through the steps (click on the <<Previous button to go back).
3. Once complete, click on theOK button to save all changesand close theConfiguration Wizard.
4. To discard all changes, click on theCancel button.

See Also:
• "Viewer / Editor Settings" on the previouspage

Clear Search History
To clear the search history:

• From the Find it EZ menu, select Tools -> Clear Search History. All previous search expressionswill be deleted (except
for the current search expression).

See Also: 
• "View Recent Search History" on page 1

Index Management
This section provides instructions to clear your index, to compact or shrink your database, and to view your index summary report.
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Clear Index or Subset
Alert: When clearing the indexor a subset, saved search results are also deleted. If anyof the selected itemsabout to be
removed from the indexare included in either the session (search) history or anypreviously saved search results, a warning / alert
will appear indicating that search resultswill be affected/lost if you proceed. The session search history selectionswill remain, but
will no longer contain the subset of documents that were removed from the underlying index.See:"View Search Result History"
on page 97.

1. From the Find it EZ menu, select Tools -> Index Management. The Index Maintenance dialog boxwill appear.

2. To clear the entire index:

a. Click to choose theClear the entire index option.

b. Click on theApply button.

OR

3. To clear a subset(s) of the index:

a. Click to choose theClear the following subset option. A check-boxwill appear before each project and subset.
b. Click to check the project(s) or subset(s) you want to clear.

c. Click on theApply button. The selected project(s) and or subset(s) will be cleared from the index.

Compact and Shrink Database
In most cases the indexwill be 1GBor under, though it dependson what is being indexed. The current size of your database is shown
at the bottom of the Index Maintenance dialog box (see instructionsbelow). If you feel this is too large (e.g. you are running out of
hard drive space), you can shrink the database to try and reclaim some of that space. The benefits can be significant as the under-
lying database is a "grow only" type system. If, for example, you had 15000 documents at one point and only have 200 now, you could
reclaim a lot of space.

1. From the Find it EZ menu, select Tools -> Index Management. The Index Maintenance dialog boxwill appear.
2. Click to choose theCompact and Shrink the Database option.
3. Click on theApply button.

View Index Summary Report
1. From the Find it EZ menu, select Tools -> Index Management. The Index Maintenance dialog boxwill appear.

2. At the bottom of the dialog box, click on theView Index Summary Report link. The Index Summary report will open in the
selected viewer.

3. The report will include the following data:

• Location
• Type
• Host
• File Path or Database
• Document
• Sections
• Words

See Also:
• "Viewer / Editor Settings" on page 28
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Get Started
This section provides step-by-step procedures required to use the variousFind it EZ 'wizards' to walk you through targeted applic-
ation tasks, to perform a regular search, to use the expression builder, and to understand the featuresof theSearching statuswin-
dow (includingmultitasking while searching, errors, and stopping a search).

Use Find it EZ Wizards
A 'wizard' is a sequence of dialog boxes that lead you through a series of well-defined steps. This section will introduce you to the
Search Wizard and the following Find it EZ wizards:

• SearchWizard

• CompareWizard

• DocumentWizard

• ReplaceWizard

• ConfigurationWizard

SearchWizard
This section describeshow to launch theSearch Wizard, understand the purpose of each unique option, and to set it to show (or
not) on application start-up.

Launch the Wizards
TheSearch Wizard walks you through the steps required to set up and run a search. If theShow on Start-up option is selected,
theSearch Wizard will open automaticallywhen you start up Find it EZ.

Note: TheShow on Start-up option is selected bydefault when Find it EZ is run for the first time.

If theSearch Wizard doesnot open automatically, follow these steps:

1. Click on theWizards button. TheWizardsdialog boxwill appear.

See: "WizardsOptions" on the next page for a description of each option.

a. Click to choose the desired search option.

b. Click on theNext button to continue.

2. Create or select a new project:

a. Click to choose theUse an existing project option, then select the desired project from the drop-down list,

OR

b. Click to choose theCreate a new project option and enter the desired project name into the corresponding text box.

See:"Projects" on page 73.

c. Click on theNext button to continue.

3. Select the file types to include in your search:

a. Click to checkeach item you want to include.

b. Click on theNext button to continue.
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4. Select the desired search locations:

a. Click to checkanyFile Repositories you want to search.
b. Click to checkanyDatabases you want to search.
c. Click on theNext button to continue.

5. Enter connection information for each repository or database.

Note: If more than one source location is selected, connection information will be requested for each source.

a. Click on the Test Connection button to verify your connection.
b. Click on theNext button to continue.

6. Enter your search criteria:

a. Enter a search term into the Find text box.
b. Click on theStart Search button. A search dialog boxwill appear showing the statusof the search.

7. Once the search is complete, resultswill appear in theResultswindow.

Wizards Options
Refer to the image and table below for a description of each option:
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# Wizard Menu Shortcut Use Case / Document Produced

Search for a specific data-
base object, code snippet, or
a variable to find any ref-
erences throughout all of my
source code (including within
reports and databases)

See:"Perform aRegular
Search" on page 60.

Use Boolean or Wildcard search expressions to find all ref-
erences to any text throughout your entire code stack,
data files or office documents. Search results are dis-
played in themain application window with highlighted
match details for each document containing a "hit." Inter-
active to-do list results can then be used to launch an editor
of your choice to workwith the original source document,
or lists can be updated, saved, printed or exported to vari-
ous file formats such asHTML, text, CSVor Excel spread-
sheets asneeded.

Compare database schema,
reports, or files for dif-
ferencesbetween versions

Compare -> Documents,
Reports & Databases

Masscompare release branches for differences in ver-
sionsof your code files, reports or database schema and
SQL code objects (procedures, triggers, views, functions).
Drill downwith detailed "diff" tool to view highlighted side-
by-side target and source file differencespinpointing
exactlywhat has changed. Export results to Excel lists or
scrollable, highlighted HTML.

Extract database objects
(tables, stored procedures,
views, etc.) used inmy
reports

Document -> Business
Intelligence -> SQL Code
Extract

Create a list of data source connections, server host
names, database names, tables, procedures, views, table
links (joins), call statements, parameters and includesboth
embedded SQLSELECT statements fromwithin your
reports or the underlying database SQL code content. Res-
ults are exported to Excelwith customizable column selec-
tions.

Generate detailed content
documentation for my
reports

Document -> Business
Intelligence -> Report
Definition

Automatically generate detailed report documentation for
your entire report library in a consistent layout and format.
Complete report specifications in a standard format are
exported in your choice of HTML or TXT format. Create a
single file for each report processed, or export all results
into file with page-breaks for each report.

Extract all SQL code used in
my reports

Document -> Business
Intelligence -> Show SQL
Queries

Extract all SQL statements embedded within your reports,
including run-time derived SQL commandsand table joins
from a visual drag-and-drop designer. Export doc-
umentation to your choice of HTML or TXT format. Create
a single file for each report processed, or export all results
into file with page-breaks for each report.

Create a database cross-ref-
erence for my reports

Document -> Business
Intelligence -> Database
Cross-Reference

Create a complete database cross-reference for all of
your reports. List tables and database fields used within
your reports by location (where used/referenced). Results
are exported to Excelwith customizable column selections.

List allmy reports, including
printer and update inform-
ation

Document -> Business
Intelligence -> Report List-
ing

Create a real-time list of all of your reports, including
author information, last updated, where located, etc. Res-
ults are exported to Excelwith customizable column selec-
tions.
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# Wizard Menu Shortcut Use Case / Document Produced

List the schedule for my
reports inside an SAP BOEor
Crystal Server Repository

Document -> SAP BOE /
Crystal Server -> Report
Schedules

Create a real-time list of all CrystalReport schedules
within your SQL Server Reporting Servicesdatabase,
including deliver to, output format, schedule frequency,
data or event triggers, report parameters andmore. Res-
ults are exported to Excelwith customizable column selec-
tions.

List the security for my
reports inside an SAPBOEor
Crystal Server Repository

Document -> SAP BOE /
Crystal Server -> Security
Listing

Create a real-time list of CrystalReport security access for
all schedulesand reports located within your SAPBOEor
Crystal Server. Results are exported to Excelwith cus-
tomizable column selections.

List the schedule for my
reports inside a SQL Server
Reporting Services (SSRS)
database

Document -> SQL Report-
ing Services -> Report
Schedules

Replace CrystalReport data
source connectionsor qual-
ified table names

Replace -> Crystal
Reports -> Data source
connections or qualified
table names

Masschange the data source connections for a set of Crys-
talReports. This is usefulwhenever you aremigrating
reports between development->test->production host
environments, a database ismoved to a new server, a
database name has changed, the database type has
changed or you want to change the data source con-
nection type (for example you want to switch fromODBC
toOLEDB connection or vice-versa). Output can over-
write the original source files or be written to a new target
folder (recommended).

Replace the username, pass-
word, server or database of
myReports in an SAPBOE
or Crystal Server repository

Replace -> Crystal
Reports -> BOE BI Data-
base logon information

Masschange CrystalReport database login (author-
ization) information on a set of scheduleswithin an SAP
BOEor Crystal Server. Useful to change a large set of
schedules rather then having to change each report sched-
ule individually through the CrystalManagement Console.
Output can over-write the original source files or be written
to a new target folder within the repository (recom-
mended).

Show Wizards on Start-up
At the bottom, left corner of theWizards dialog box there is aShow on Startup check-box. Click to un-check this item to prevent the
Search Wizard from launching automatically each time you start the program.

See Also:
• Use Pre-Indexed Documents1

• "ApplyFile Filter" on page 77

• "Use the Expression Builder" on page 65

• "WorkWith Search Results" on page 97

1This feature saves time if your repository does not change often. When checked, the search won't look for changes.
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• "SearchWithin Result Documents" on page 101

• "Set User Options" on page 1

SearchWizard
This section takes you through each step required to use theSearch Wizard: launch the wizard (two ways), create or select a pro-
ject, select file types to include, select search location(s), enter connection information, enter search criteria and start the search, and
enter connection information and update reports.

Launch the Search Wizard
TheSearch Wizard is launched only via theWizards button (i.e. thiswizard cannot be accessed via themenu), as follows:

1. See: "SearchWizard" on page 31.

2. Click to choose one of the followingSearch Wizard options:
• Option 1: Search for a specific database object, code snippet, or variable to find any reference

throughout all of my source code (including within reports and databases)
• Option 10:Replace the username, password, server or database of my Reports in an SAP BOE or Crys-

tal Server repository
3. Click on theNext >>button to continue.
4. TheSearch Wizard will open.

Create or Select a Project
Projects are used to group and save search settings, filters, and directories between sessions.
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1. "Launch the SearchWizard" on the previouspage. The following dialog will appear:

2. To use an existing project for your search:

a. Click to choose theUse an existing Project option (selected bydefault).
b. From the project drop-down list, click to select the name of the existing project (i.e. settings) you would like to use for

your search.

3. To create a new project for your search:

a. Click to choose theCreate a new Project option.
b. In the project text box, enter the name of the new project.

4. To use pre-indexed documents for this search, click to check the Use pre-indexed documents check-box.

5. Click on theNext >>button to continue.

Note: To go back to theSearch Wizard options, click on the << Previous button.

Select File Types to Include
Anumber ofSearch Wizard options include this dialog. See example below:

Note: TheShow More link located to the right of the list below, when clicked, auto refreshes the list of available items to include
the "hidden" but available source items (See:"Set Source Items" on page 24.When a "hidden" item is checked, it will become vis-
ible going forward on theSource panel on themain screen and automatically be included in your project settings.
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1. In theSelect file types to include list, click to select (i.e. check) the check-boxpreceding each file type you want to include
in your search. See note above re:Show More.

2. Click on theNext >>button to continue.

Note: To go back to theSearch Wizard options, click on the << Previous button.

Select Search Location(s)
Anumber ofSearch Wizard options include this dialog box. See example below:

Note: TheShow More link located to the right of the lists below, when clicked, auto refreshes the list of available items to include
the "hidden" but available source items (See:"Set Source Items" on page 24.When a "hidden" item is checked, it will become vis-
ible going forward on theSource panel on themain screen and automatically be included in your project settings.
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1. In the File Repositories list, click to select the source repository repositorieswithin which you want to search.
2. In theDatabases list, click to select the source database(s) within which you want to search.

3. Click on theNext >>button to continue.

Note: To go back to the previous step, click on the << Previous button.

Enter Connection Information
The following example is for SQL Server Reporting Services (SSRS) connection information.
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1. On theOptions tab (selected bydefault), enter the connection information for the selected source.
2. To test the connection, click on the Test Connection button.
3. To apply a report filter, click on theReport Filter tab and see linksbelow.
4. To continue, click on theNext >>button.

Enter Search Criteria and Start Search
This dialog is only included in the firstSearch Wizard option. See below:
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1. From theSearch Type drop-down list, click to select one of the following options:
• Boolean (can search entire document or line by line)
• Wildcard (will search line by line)

2. In the Find text box, enter the desired search expression.

Tip: Click on theMore Information link. Enter a word or phrase. Or, to use supported Boolean operators: OR, AND,
and NOT, search termsmust be enclosed in curly brackets. For example: {Order} AND {By}.

• To view or select from a list of recent search expressions, click on the field to view a drop-down list and click to select
the desired search expression.

• To perform a search using theBoolean Search Builder, click on theExpression Builder button. Refer to the
See Also links below.

3. If you have selected 'Boolean' in step 1 above, click to choose aScope option:
• Search Entire Document
• Search Line by Line

4. In the Filters section, click to select the desired filters:
• Word Match
• Case Sensitive
• Include Comments
• Comments Only

5. To launch the search, click on theStart Search button. ASearching ... dialog will appear. See example below:
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6. To stop the search, click on theStop button.
7. Once the search is complete, any resultsmatching your search criteria will appear in theResultswindow.

See Also:
• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

• "Create or Select a Project" on page 35

• "Local or NetworkFolders" on page 75

• "Repositories" on page 78

• "Databases" on page 132

• "ApplyFile Filter" on page 77

• "ApplyReport Filter" on page 80

• "Projects" on page 73

• "Use Pre-Indexed Documents" on page 64

• "Example Boolean Expressions" on page 66

• "Find it EZ CustomBoolean Syntax" on page 66

• "WorkWith Search Results" on page 97

CompareWizard
This section takes you through each step required to use theCompare Wizard: launch the wizard (two ways), choose compare
source and target, update index for compare, select documents to compare, view compare results summary, and view compare res-
ults detail.

Launch the Compare Wizard
TheCompare Wizard can be launched via theSearch Wizard or via themenu. See below:
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1. Launch theCompare Wizard via theSearch Wizard:
a. See: "SearchWizard" on page 31.

b. Click to choose the followingSearch Wizard option:
• Option 11:Compare database schema, reports or files for differences between versions

OR

2. Launch theCompare Wizard via themenu:
• From the Find it EZ menu, selectCompare -> Documents, Reports & Databases

3. TheCompare Wizard will open.

Choose Compare Source and Target

Note: Microsoft Excel spreadsheets and SAPDashboards (Xcelcius) are not supported by this tool.

1. To compare a project:

a. In theSource or Target section, choose theProject option.
b. From the project drop-down list, click to select the name of the project you want to compare.

c. To change settings for the selected project, click on the corresponding gears icon.

d. If desired, click to check theUse pre-indexed documents check-box.

See:"Use Pre-Indexed Documents" on page 64
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2. To compare search results:

a. In theSource or Target section, choose theSearch Results option.
b. From the search results drop-down list, click to select the desired search results. Note the date and time.

3. In theCompare By section, click to choose one of the followingmethodsof comparison:
• Name
• Custom

4. To continue, click on theNext >>button.

Update Index for Compare
Once you choose the compare source and target and click on theNext >>button, the indexbeginsupdating. See example below:

The next example contains some errors:
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Use the horizontal scroll bar to view details of anyerrors, then correct any issues.

Once the indexupdate is complete, click on theNext >>button to continue.

Select Documents to Compare
After selecting the source and target and then allowing the index to update, you can select the documents for comparison. See
example below:
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Click to checka category to 'select all' for a category. Or, click on the '+' to expand a document type and click to check the desired doc-
uments for comparison.

Once complete, click on theNext >>button to continue.

View Compare Results Summary
Once the compare is complete, the following summarywill appear. See example below:
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To close theCompare Wizard and view the results in theResultswindow, click on the Finish button.

See Also:
• "Search Locationsand Source Settings" on page 75

• "Use Pre-Indexed Documents" on page 64

• "View Compare ResultsDetail" on page 113

• "Compare Files, Reports, and Databases" on page 113

Compare Files, Reports, and Databases
Refer to this section for step-by-step instructions required to start or modify a comparison, show differences, filter/search/export com-
pare results, view compare result details, expand/collapse compare results, compare status colours, find in source or target, show dif-
ferencesonly, export compare details, and copyor print compare results.

View Compare Results Detail

See:"CompareWizard" on page 42.

After completing a comparison using theCompare Wizard and viewing the results summary, click on the Finish button to view the
Comparison Resultswindow. See example below:
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Start New Compare

1. "View Compare ResultsDetail" on the previouspage.

2. In the upper, left corner of theComparison Resultswindow, click on the button. You will be returned to theCom-
pare Wizard to start a new comparison.

Modify Current Compare

1. "View Compare ResultsDetail" on the previouspage.

2. In the upper, left corner of theComparison Resultswindow, click on the button. You will be returned to theCom-
pare Wizard to select which documents you want to compare.

Show Differences

See:"CompareWizard" on page 42.

At the top of theComparison Resultswindow, there are a number ofShow Differences view filters available. See below:

Click to check the desired check-box to view that selection. The first three filters are checked bydefault. Click to un-checkanyas
desired:

• Only in Source
• Only in Target
• Different

To view comparison results that arematching, click to check the Identical check-box.

Filter or SearchCompare Results

1. At the top of theComparison Resultswindow, locate the Filter text box.
2. Enter the desired filter/search text into the text box. The results list will update automatically to show only those resultsmatch-

ing your specified criteria.

Export Compare Results
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See: "CompareWizard" on page 42.

1. "Filter or Search Compare Results" on the previouspage.

2. At the top of theComparison Resultswindow, locate and click on theExport List button. ASave As dialog will appear.
3. Enter a File name.

4. Click on theSave button.

Note: The list will be saved in *.xlsx file format.

5. The saved list will open automaticallywith the selected viewer/editor.

6. The following data will be included in the exported file:

• Source, Target, and Date Created

• View filter(s)

• Type

• # Differences

• Document

• Source Host

• Source File Path or Database

• Target Host

• Target File Path or Database

• Compared To

7. Save the file asdesired.

Expand orCollapse Compare Results

In the results list on theComparison Resultswindow, results are grouped bydocument and document type. To expand or collapse
a result group, click on the '+' or '-' button, respectively.

Compare Status Colours

See: "CompareWizard" on page 42.

At the bottom of theComparison Resultswindow, there is a result status colour key. See below:

Differencesbetween the source and target content are highlighted in the above colours.

To show differencesonly, click to check theShow differences only check-box.

Find in Source or Target

1. At the top of theSource or Target window, locate the Find text box.
2. Enter the desired filter/search text into the text box.

3. Click on the right arrow button to find next or the left arrow button to find previous. Content matching your search criteria will
be highlighted in purple.

4. Repeat to view all instancesmatching your search criteria.

Show Differences Only

To view only the differences in content between the source and target, click to check theShow differences only check-box.
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Export Compare Details

At the bottom right of theComparison Resultswindow, locate and click on either theHTML or Excel button. Source and target
detailswill open in the selected editor. Save asdesired.

See Also:
• "CompareWizard" on page 42

• "Select Documents to Compare" on page 1

• "Viewer / Editor Settings" on page 28

DocumentWizard
This section takes you through each step required to use theExport Wizard: launch the wizard (two ways), create or select a pro-
ject, select file types to include, select search location(s), enter connection information, select recurrence and what to include, and
choose report optionsand export report.

Launch the Document Wizard
TheExport Wizard can be launched via theSearch Wizard or via themenu. See below:

1. Launch theExport wizard via theSearch Wizard:
a. See: "SearchWizard" on page 31.

b. Click to choose one of the followingSearch Wizard options:
• Option 2:Extract database objects (tables, stored procedures, views, etc.) used in my reports
• Option 3:Generate detailed content documentation for my reports
• Option 4: Extract all SQL code used in my reports
• Option 5:Create a database cross-reference for my reports
• Option 6: List all my reports, including printer and update information
• Option 8: List the schedule for my reports inside an SAP BOE or Crystal Server repository

• Option 9: List the security for my reports inside an SAP BOE or Crystal Server repository

OR

2. Launch theExport Wizard via themenu:
• From the Find it EZ menu, selectReports -> Business Intelligence -> [Any Option]
• From the Find it EZ menu, selectDocument -> SAP BOE / Crystal Server -> [Any Option]

3. Click on theNext >>button to continue.
4. TheExport Wizard will open.

Select Recurrence and What to Include

Note: Recurrence is only selected for option 8 of the SearchWizard; List the schedule for my reports inside an SAP BOE
or Crystal Server repository (also accessed from themenu viaDocument -> SAP BOE / Crystal Server -> Report Sched-
ules).
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1. Click on theRecurrence drop-down. A list of optionswill appear, as below:

These are items that match up to selections in the BOE repository schedules.

2. Click to select the desired recurrence.

3. If you want to show the default settings, click to check theBase Reports only check-box.

Note: Crystal reports has "Default Settings" and "Per Instance Settings." Default settingsbelong to the report itself (the
base report) and then each time you schedule a report you can give the report its own schedule/settings. This allowsyou
to just return the defaults as youmayhave a large number of one-time scheduled reports that will never be run again.

4. To continue, click on theNext >>button.

Choose Report Options and Export Report
The following dialog is used with theExport Wizard. See example below:
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1. In theColumns section, choose to Include all columns or toSelect from the following.
2. IF the second option is chosen:

a. In theAvailable list, click to select the report column you want to include, then click on the ->button tomove the selec-
ted column to the Included list.

b. Tomove all columns from theAvailable list to the Included list, click on the ->->button.
c. To remove all columns from the Included list, click on the <<button.
d. To remove a single column from the Included list, click to select the report column you want to remove, then click on

the <button.
3. Once complete, click on theExport button to generate and save your report. The Searching dialog will appear.

See Also:
• "Create or Select a Project" on page 35

• "Select File Types to Include" on page 36

• "Select Search Location(s)" on page 37

• "Enter Connection Information" on page 38

• "Navigation" on page 1

• "Launch the DocumentWizard" on page 1
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ReplaceWizard
This section takes you through each step required to use theConversion Wizard: launch the wizard (two ways), select where to
look for reports, enter connection information, select report destination folder, select report tables to change, choose new connection
type, and confirm information and convert.

Launch the Replace Wizard
TheConversion Wizard can be launched via theSearch Wizard or via themenu. See below:

1. Launch theConversion wizard via theSearch Wizard:
a. See: "SearchWizard" on page 31.

b. Click to choose the followingSearch Wizard option:
• Option 7:Replace Crystal Report data source connections or qualified table names

OR

2. Launch theConversion Wizard via themenu:

• From the Find it EZ menu, selectReplace -> Crystal Reports -> Data source connections or qualified
table names

OR

• From the Find it EZ menu, selectReplace -> Crystal Reports -> BOE BI Database logon information
3. TheConversion Wizard will open.

Select Where to Look for Reports
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1. Select where you want to look for reports:

a. Choose Local File System.

OR

b. ChooseBusinessObjects BI Platform 41 Repository.
2. Click on the corresponding project drop-down list and select the desired project.

3. If you have one or more search results selected, click to choose theUse selected documents option. This is a wayof run-
ning the report with only a subset of itemsbased on your last search.

4. To continue, click on theNext >>button.

Select Report Destination Folder

1. To place the updated reports in a new folder, click to choose theNew Folder option.
a. Click on the folder icon to the right of the text field. ASelect Folder dialog will appear.
b. Create or navigate to and select the desired folder.

c. Click on theSelect Folder button. The selected folder path will now appear in the text field.

OR

2. To overwrite the original files, click to choose theOverwrite original files option.

Alert: Only valid connectionswill be replaced. It is strongly recommended that you save to a separate folder and verify
the results.

3. To continue, click on theNext >>button.
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Select Report Tables to Change

1. A list of report tables from the selected location will load. See example above:

2. To stop Find it EZ from loading report tables, click on theStop button.
3. For each report table to want to change, click to check the preceding check-box. Note that all report tables in the selected loc-

ation are selected bydefault.

a. To de-select all available report tables, click on theSelect None button, then click to checkonly those you wish to
include.

b. To select all available report tables, click on theSelect All button, then click to uncheckonly those you wish to exclude.
4. To continue, click on theNext >>button.
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Choose New Connection Type

1. Select the new connection type:

a. Click on the Type field to view a list of connection types.

b. Click to select the desired connection type.

2. Enter and/or select connection parameters:

a. For Access / Excel (DAO) and xBase, click on the folder icon and navigate to and open the desired folder.
b. ForODBC, select theODBC DSN and enter theUsername andPassword.
c. ForOLEDB,Configure OLE (via Data LinkProperties) and enter theUsername andPassword.

i. Click on theConfigure OLE button. TheData Link Properties dialog will appear. This dialog is opened by
default.

ii. Select theProvider and click on theNext button.
iii. Enter Connection parameters and click on the Test Connection button.
iv. Enter any further required details (depending upon the selectedProvider).
v. Click on theOK button.

d. ForOracle Server, enter theService,Username, andPassword.
3. Tell Find it EZ what you want to do:

a. In the I want to section, click to choose the desired option.
4. To continue, click on theNext >>button.
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Confirm Information and Replace

1. Review the following information:

• Save Reports To
• New Connection Type
• Connection Parameters

2. If changesare required, click on the << Previous button. Click the button again to return to previous steps.

See: 
"SelectWhere to Look for Reports" on page 54

"Select Report Destination Folder" on page 55

"Select Report Tables to Change" on page 56

"Choose New Connection Type" on the previouspage

3. If the information is correct, click on theConvert button. AConversion Status notification will appear. See example below:
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4. To stop the conversion, click on theStop button.
5. Once the conversion is complete, Microsoft Excelwill lauch and open aConversion Results spreadsheet containing a

detailedConversion Log.

Enter New Connection Information and Update Reports
This dialog appears onlywhen option 10 is selected from theSearch Wizard. See example below:

1. In the I want to change section, click to choose the desired option.

2. In theUpdate the following section:
a. Click to select (i.e. check) each item that you want to update.

b. For each selected item, enter the new connection information in the corresponding text box.

Note: Only checked itemswill be updated.
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3. In theAdditional Options section:
a. Click on the down arrow to view the drop-down list.

b. Select the desired option from the list.

4. To start the update, click on theUpdate Reports button.

See Also:
• "Enter Connection Information" on page 38

• "ReplaceWizard" on page 54

Perform a Regular Search
A regular search is performedwithout the use of theSearch Wizard. Search settingsare applied 'manually' and the search is ini-
tiated from the Search Bar.

In addition to using theSearch Wizard, you can run a regular search as follows:

Select a Project
1. From the Find it EZ menu, selectProjects. The currently active project appears preceded bya checkmark, as in the

example below:

2. Select the name of the project for which you want to perform a search. The selected project namewill appear in the Find it
EZ window title bar.

Configure Source Location(s)
1. From theSource frame on the left, select the source(s) within which you want to search; (i.e.Repositories,Databases,

Report Utilities,Programming Languages,Documents).
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a. Click on a source. A [Project Name] Project Settings dialog will appear, showing settings for the selected source.
b. To expand or collapse aSource category, click on the corresponding blue up/down arrow.
c. Configure settings, as required. Refer to the links below for details:

See:
• "Local or NetworkFolders" on page 75

• "Repositories" on page 78

• "Databases" on page 132

• "Programming Languages" on page 92

• "Documents" on page 94

• "Report Utilities" on page 95

2. Example - search Local or NetworkFolders:
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Set SearchOptions
From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.
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Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =None. Search
options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last indexed doc-
ument content and therefore will not refresh content with latest updates. Use this filter if it is known that the source documents are
changed infrequently or have not changed since the last Find it EZ project indexing.

See topics to follow...

Boolean Search
UseSearch Type =Boolean Search when you are either looking for a single word or phrase or want to combine one or more search
terms into a Boolean expression. This allowsyou to search for field (AOR B) , [(A AND B ) OR C], etc.

Boolean search unlocksall of theScope optionsand Filter selections, allowing you to evaluate the search expression on a line by line
basis or acrossan entire document, as desired.

Wildcard Search
Themost basic form of a wildcard search is the "*" search; thismeans showme everything in the selected documents.
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Wildcard searching doesnot allow Boolean expressions ( AOR B, AAND B, etc.) in exchange for allowingmore control over partial
matching.

For example if you search for "User*," the systemwill only findmatcheson items that start with "User." In a Boolean search, you only
have the option ofWordMatch (Must be UserName) or PartialMatching ( UserName, NewUser, BreadUserBread, etc.).

Because of the way the engine is setup, there are a few limitations:

• You can only do amatch on a single line.

• Wildcard is "stopped" on a whitespace boundary (i.e. If the text in the document is "UserName Food Type" and you use
"User*Type" it will not find amatch. However "User*" willmatch on the first word; " Foo*" on the second. If it was "User-
Name.Food.Type" then "User*Type" willmatch on the whole thing.

Word Match Filter
When theWordMatch setting is turned on in Filters, the result must be found between a white space boundary (these include
spaces, tabs, and line feeds).

Use Pre-Indexed Documents
This filter is located on theOptions panel; in the Filters section. Click to check the check-box to apply this filter.

For better search performance, this filter will use the last indexed document content and therefore will not refresh content with latest
updates. This is not an issue if it is known that the source documents are changed infrequently or have not changed since the last
Find it EZ project indexing.

Enter Target Keyword(s)
On the search bar (see image below), enter the desired search text into the Find text box.

Example:

Start Your Search
1. To initiate the search, click on theSearch button. ASearching window will appear, showing the statusof the search. See

"SearchingWindow" on page 68 for details.

2. Once complete, theSearch Complete dialog boxwill appear, as in the example below:

3. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
"WorkWith Search Results" on page 97 for details.
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Note: After performing a search, settings can be saved to a Project for later use again.

ViewSearch History
Search history can be viewed from the search bar. To view search history:

1. Click on the down arrow button located on the right of the Find field. A drop-down list of previous search expressionswill
appear.

Note: This history is limited to 26 itemsand is preserved between program sessions. New search termsare added 'top
down.'When the list exceeds26 items, the bottom item dropsoff.

2. Click to select the desired search expression.

See Also: 
• "SearchWizard" on page 31

• "Projects" on page 73

• "Set User Options" on page 21

• "Use the Expression Builder" below

• "WorkWith Search Results" on page 97

• "Clear Search History" on page 29

• "View Search Result History" on page 97

Use the Expression Builder
This section provides instructions to perform a search using theBoolean Search Builder, building a search query, reviewing
example Boolean expressions, and creating a valid Boolean expression using Find it EZ customBoolean syntax.
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Open Boolean Search Builder
To launch theBoolean Search Builder, click on theExpression Builder button located on the right side of the search bar. See
below:

Build SearchQuery
1. Click on theExpression Builder button to launch theBoolean Search Builder. A blank search query item is added.

2. To applyNOT to the current search query, click to check the correspondingNOT check-box.
3. Select the required number of curly brackets from the left curly bracket drop-down list.

4. Enter the desired search text into theSearch Text text box.
5. Select the required number of curly brackets from the right curly bracket drop-down list.

6. Select the desired Boolean operator (AND or OR) from theOperator drop-down list.

Find it EZ Custom Boolean Syntax
Find it EZ uses custom syntax so that itemsare recognized asBoolean operators rather than search text.

For example, to have the Boolean operator "AND" be recognized, youmust enclose the search terms in curly brackets, e.g. {this}
AND {that}. The use of curly brackets is special syntax to our software. TheBoolean Search Builderwizard helpswith this for build-
ing/managing complexexpressions, especially for first time users.

Example Boolean Expressions
For Search Syntax Examples including Boolean andWildcard, visit: https://www.finditez.com/support/#syntax.

AddNewSearchQuery Item
1. See:"Build SearchQuery" above.
2. To add a new search query item, click on theAdd Itembutton. A new, blank search query item line will be added.

https://www.finditez.com/support/#syntax
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Remove SearchQuery Item
1. See:"Build SearchQuery" on the previouspage.
2. To remove a search query item, click on the right arrow button preceding the row to select the item.

3. Click on theRemove Itembutton. The selected itemwill be removed from the search query.

Paste SearchQuery Item From Clipboard
To copya search query item to the clipboard:

1. Locate the desired searc h query item text.

2. Highlight the desired text.

3. Press the [Ctrl] + [C] keyson your keyboard. The selected text will be copied to the clipboard.

To paste the copied search query item into a search query:

1. See:"Build SearchQuery" on the previouspage.

2. Click on thePaste from clipboard button. A search query item line will be created for each instance of search text and the
correct curly brackets and operatorswill be applied. See example below:

Example:
Copied search query item: {insert} and {{into} AND {{Order} OR {Customer}}}
Resulting search query inBoolean Search Builder:

Import SearchQuery Values From File
1. See:"Build SearchQuery" on the previouspage.
2. Click on the Import list from file button. AnOpen dialog boxwill appear.

3. Navigate to and select the file containing the list of line separated values to use in the query.

Note: Accepted file types include *.txt and *.csv.

4. Click on theOpen button. A search query item line will be created for each instance of search text.

5. ApplyNOT, curly brackets, and operators (AND/OR) as required.
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ViewSearchQuery Details
Asyou are building your search query using theBoolean Search Builder, note that the entire search expression is shown in the
Search Query boxat the bottom of the dialog box.

Apply Boolean Expression to Search
1. See:"Build SearchQuery" on page 66.
2. To apply the Boolean expression to your search, click on theOK button. The search querywill be entered into the Find text

box located on the search bar.

3. To launch the search, click on theSearch button.

Searching Window
During a search, theSearching ... statusdialog appears. See example below:

Refer to the table below for a description of each data element:

Searching Data Element Description

Search Terms This is the search expression entered into the Find text box located on the Search Bar.

Search Options This is a summaryof the currentSearch Type,Scope, and Filters settingson theOptions
panel.

Indexed This showsa visual progressdisplay and current count of the total number of documents
indexed vs the total number of documents available in the selected sourceson theSource
panel.

Scanned This showsa visual progressdisplay and current count of the total number of indexed doc-
uments (above) that have been scanned for the current search criteria (i.e. Search Terms).
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Searching Data Element Description

Matches This is the total number of instanceswhere the current search expression hasbeen found in
the source documents.

Errors/Warnings This is the total number of errors or warnings that have been generated while connecting
and/or scanning the source documents for search criteria matches. Once the search is com-
plete, these can be viewed in the Resultswindow byclicking on the Errors tab (click on an
error row to view details).

Duration This is the elapsed time used to indexand scan the selected source documents

StatusTable This is the currentScan Source, Type, andDocument being scanned for matches.

MultitaskWhile Searching
Once a search is launched, you can continue working on other programswhile Find it EZ runsunattended in the back-ground.While
a search is running, you can not minimize the Find it EZ program or use anyother window in Find it EZ as the search dialog box keeps
focusuntil completed or cancelled. However, Find it EZ will go to the background on your desktop if you launch another program
(e.g.Word, a browser, VisualStudio, etc.).

Hide or ShowSearching Details
While a search is taking place, you can view or hide search details. See examplesbelow:

Click on the + Show Details link to expand the table showingScan Source, Type, andDocument. See example below:
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To hide details, click on the - Hide Details link.

ShowSearch Results
Once a search is complete, the progressbarswill stop advancing and a "Search Complete" notification will appear (see example
below).

To view results, click on theShow Results button.

The resultswill appear listed in theResultswindow. See example below:
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Stop Searching
To cancel a search in progress, click on theStop button. A notification will appear at the bottom of the dialog. See example below:

ViewSearch Errors
If a search is complete and the error count is > 0, you can view error details as follows:
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1. Note the error count on theSearch Completed with Errors dialog. See example below:

2. Click on theShow Results button.
3. In theResultswindow, click on theErrors tab.

4. Locate the error for which you want to view details and double-click on the row. Or, right-click and selectView Error from the
context menu. An error details dialog will appear. See example below:

5. Review details of the error.

6. To check your project settings, click on theCheck Settings button.
7. To report a bug, click on theReport A Bug button.
8. To close the error details dialog, click on theClose button.

See Also:
• "WorkWith Search Results" on page 97

• "Search Locationsand Source Settings" on page 75

• "Find it EZ Support" on page 162
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Projects
This section provides step-by-step procedures to add, edit, switch, clone, rename, set active, delete, or save a project and its set-
tings.

From the Find it EZ menu, selectProjects -> Manage Projects. TheManage Projects dialog boxwill appear, as below:

Add a New Project
1. Click on theAdd button. A pop-up will appear.
2. Enter the name of the new project.

3. Click on theOK button. The new project will be added to the list.

4. To close theManage Projects dialog box, click on theClose button.

Edit a Project
1. In the projects list, click to highlight the project you want to edit.

2. Click on theEdit button. TheProject Settings dialog boxwill appear.



Switch Between Projects

74 © 2010 - 2016 Find it EZ Software Corp

Switch Between Projects
1. The name of the currently viewed project is shown in the bottom, right corner of themain screen. See below:

2. To switch to another project:

• From the Find it EZ menu, selectProjects -> [Project Name]. The new project will be loaded.

Clone a Project
1. Click to select the project you want to clone (i.e. copyall settings).

2. Click on theClone button. A pop-up will appear.
3. Enter a different name for the new, cloned project.

4. Click on theOK button. The cloned project will be added to the list.
5. To close theManage Projects dialog box, click on theClose button.

Rename a Project
1. Click to select the project of which you want to change the name.

2. Click on theRename button. A pop-up will appear.
3. Change the name, asdesired.

4. Click on theOK button. The renamed project will appear in the list.
5. To close theManage Projects dialog box, click on theClose button.

Set Active Project
1. Click to select the name of the project you want to set as the active project.

2. Click on theSet Active button. The project will appear in the list followed by the word "(active)."
3. To close theManage Projects dialog box, click on theClose button.

Delete a Project
1. Click to select the name of the project you want to delete.

Note: The active project cannot be deleted.

2. Click on theDelete button. The selected project will be immediately removed from the list.

3. To close theManage Projects dialog box, click on theClose button.
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See Also:
• "Local or NetworkFolders" below

• "Repositories" on page 78

• "Databases" on page 132

• "Programming Languages" on page 92

• "Documents" on page 94

• "Report Utilities" on page 95

Search Locations and Source Settings
This section providesdetailed instructions to configure project settings for Location (local or network folders, repositories, data-
bases) and File Type (programming languages, documents, report utilities) sourcesand to view/hide or apply project settings.

View or Hide Project Settings

At the bottom, left of theProject Settings dialog box, you can click to check theDo not show this window each time I select a
scan source itemcheck-box.

See Also: "Set User Options" on page 21 (in the Tips and Hints section, there is aShow project settings whenever I
select a source itemcheck-box. Click to checkor un-checkasdesired.

Apply Project Settings
When you are donemaking changes to a source, click on theApply button to apply the changes.

Location
This section providesdetailed steps required to configure project settings for local or network folders, repositories, and databases.

Local or Network Folders
This section describes the procedures required to include the local or network folders source in a search, add or edit search path(s),
include/exclude archive files, exclude files or folders from the search, and to apply file filters.

To accessproject settings for local or network folders:

1. Edit the desired project.See: "Search Locationsand Source Settings" above.

2. In the frame on the left, in the Location category, click to select Local or Network Folders. The following dialog boxwill
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appear:

Include Source

When a source is selected from the frame on the left, the Include [Source Name] check-boxat the top of the dialog box is checked
bydefault. To exclude the source from your search, click to un-check the check-box.

Note: If a source is excluded, anyexisting settings for the source are retained.

Addor Edit SearchPath(s)

To add a search path to the Local and NetworkFolders search:

1. See:"Local or NetworkFolders" on the previouspage. TheOptions tab is selected bydefault.

2. In theSearch Path(s) section, click on theAdd button. ASearch Path pop-up will appear, as below:

3. Click on the "..." button to the right of theDirectory field. ASelect Folder pop-up will appear.
a. Navigate to and select the folder you want to add asa search path.

b. Click on theSelect Folder button. The folder path will appear in theDirectory field.
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4. Note that the Include Sub Directories check-box is checked bydefault. To exclude sub directories for the selected folder,
click to un-check this check-box.

5. Click on theOK button. The new search path will be added to theSearch Path(s) list.

Note: If sub directories have been included for a given search path, a green checkmarkappears in the corresponding
Include Sub Directories? column.

To edit a search path:

1. In theSearch Path(s) list, click to highlight the search path you want to edit.
2. Click on theEdit button.
3. Repeat steps3-5 above.

To remove a search path:

1. In theSearch Path(s) list, click to highlight the search path you want to remove.

2. Click on theRemove button. The selected search path will be removed from the list.

Click on theApply button to apply your changes.

Include Archive Files

See:"Local or NetworkFolders" on page 75.

Whether or not a file is considered an Archive is determined by the file extension. If it is anyof the following support Archive types, it
will be opened asan archive and Find it EZ will search the contents:

"ARJ", "LZH", "LZMA", "RAR", "RPM", "7Z", "XZ", "BZ2", "BZ", "GZIP", "GZ", "TAR", "ZIP"

To include archive files in your Local or NetworkFolders search, locate and click to check the Include Archive Files check-box.

Exclude Files or Folders

To exclude specific files or folders from the selected directories (in theSearch Path(s) list) in your Local or NetworkFolders search:

1. See: "Local or NetworkFolders" on page 75.
2. To import a list of files to exclude:

a. In theExclude File(s) / Folders(s) section, click on the Import button. AnOpen pop-up will appear.
b. Navigate to and select the desired *.txt file.

c. Click on theOpen button. The contents of the selected file will appear in theExclude File(s) / Folder(s) list.

d. Click on theApply button to apply your exclusions.

AND / OR

3. To enter the path, file name, or wildcard to exclude:

a. Click inside theExclude File(s) / Folder(s) text boxand enter the desired text to exclude.

Note: Enter each item on a separate line. Use * for wildcards. For example, enter the path to exclude a sub-dir-
ectory, exclude a specific type of files (e.g. *.cs), etc.

b. Click on theApply button to apply your exclusions.

To clear theExclude File(s) / Folder(s) list:

• Click on theClear button. All items in the list will be removed.

Apply File Filter

To apply a file filter to a source search:
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1. See:"Local or NetworkFolders" on page 75. The Options tab is selected by default.
2. See: "Repositories" below. The Options tab is selected by default.
3. Click to select the File Filter tab.

4. To include all files, click to choose the Include all Files option. This is the default selection.

OR

5. To include only a subset of files, click to choose theOnly include this subset of Files option.
6. To add a subset:

a. Click on theAdd button. AnAdd Filter pop-up will appear. TheAvailable Files list will be populated with a list of files
included in the folders selected previously on theOptions tab.

b. Click to select the desired file(s).

Note: Select multiple itemsbyholding down the [Ctrl] key. Or, click on theSelect All button or theSelect None
button, or theRefresh button asdesired.

c. To filter by file name, use the Filename Filter:
i. Click inside the Filename Filter text box.
ii. Enter the desired file name filter, using wildcardsasdesired (e.g. *.cs, *.js, *user*, etc.).

d. Once complete, click on theAdd button. The selected fileswill be added to theOnly include this subset of Files
list.

7. To paste a subset from the clipboard:

a. Click on thePaste button. The itemwill be added to theOnly include this subset of Files list.
8. To remove file(s):

a. To remove all files from the list, click on theRemove All button.
b. To remove only selected file(s) from the list, click to select the files you want to remove, then click on theRemove but-

ton.

9. Click on theApply button to apply your changes.

Repositories
This section describes the procedures required to include the repositories source in a search, enter repository connection inform-
ation, test a repository connection, select repository folders, and apply a report filter.

To accessproject settings for repositories:

1. Edit the desired project.See: "Search Locationsand Source Settings" on page 75.
2. In the frame on the left, in the Location category, locate theRepositories sub category.

3. Click on the desired repository name. In the first example below, we have selected theBusinessObjects BI platform 4.1
repository:
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In the second example below, we have selected theGit / GitHub repository:

Connection Information - Repositories
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1. See:"Repositories" on page 78.
2. For the selected repository, select and/or enter the required connection information. Depending upon the repository selec-

ted, these settings could include:

• Authorization Name

• Hostname

• Port

• Username

• Password

• Search File Type(s)

• Git Repository

• Branch / Module or Branch

• Server URL or Server

• Collection / Project or Project

3. To have Find it EZ remember your password, click to check theRemember check-box.

4. Click on theApply button to apply your changes.

Test Repository Connection

To test your connection, click on the Test Connection button. A progresspop-up will appear with the followingmessage: "Please
wait, contacting the server."

1. If the test is unsuccessful, you will receive an "Unable to connect. Please check your settingsand try again." message, along
with a Provider Message givingmore details.

2. If the test is successful, you will receive a "Connectionmade successfully!" message.

Note: The error handling systemwill provide up to twomessages/alerts:

• Find it EZ will indicate, in general, what happened (e.g. "Unable to connect.").

• The called programmay, at times, return amore detailedmessage that is proprietary to that target system and often
provides you with more details to help you resolve the "why" wewere unable to connect.We are not in control of the con-
tent of that message or when/if it comesback, but we will alwaysdisplay and log the extra detailswhenever possible.

Select Repository Folders

To select folders, click on theSelect Folders button. A progresspop-up will appear: "Please wait, contacting the server."

1. Once connected, aSelect Folder pop-up will appear, showing a list of all folders included in the selected repository.
2. To show empty folders, click to check theShow empty folders check-box.
3. Select the desired folder(s) or sub-folder(s) by clicking to check the check-boxpreceding the desired folder(s).

4. Once selectionshave beenmade, click on theOK button. The selected folder(s) will appear in the folders list.

Apply Report Filter

To apply a report filter to a Repository search:

1. See:"Repositories" on page 78. TheOptions tab is selected bydefault.
2. Click to select theReport Filter tab.

3. To include all reports, click to choose the Include all Reports option. This is the default selection.

OR

4. To include only a subset of reports, click to choose theOnly include this subset of Reports option.



Databases

© 2010 - 2016 Find it EZ Software Corp 81

5. To add a subset:

a. Click on theAdd button. AnAdd Filter pop-up will appear. TheAvailable Reports list will be populated with a list of
reports included in the previously selected folder(s) (on theOptions tab).

b. Click to select the desired report(s).

Note: Select multiple itemsbyholding down the [Ctrl] key. Or, click on theSelect All or Select None button, or
theRefresh button asdesired.

OR

c. Use the Filename Filter to... ?
d. Once complete, click on theAdd button. The selected reportswill be added to theOnly include this subset of

Reports list.
6. To paste a subset from the clipboard:

a. Click on thePaste button. The itemwill be added to theOnly include this subset of Reports list.
7. To remove report(s):

a. To remove all reports from the list, click on theRemove All button.
b. To remove selected report(s) from the list, click to highlight the reports you want to remove, then click on theRemove

button.

8. Click on theApply button to apply your changes.

See Also:
• "Include Source" on page 76

• "ApplyFile Filter" on page 77

Databases
This section describes the procedures required to include the databases source in a search, enter database connection information,
test a database connection, reset search defaults, open resultswith the desired viewer/editor, and apply variousdatabase search fil-
ters.

To accessproject settings for databases:

1. Edit the desired project.See: "Search Locationsand Source Settings" on page 75.

2. In the frame on the left, in the Location category, locate theDatabases sub category.

3. Click on the desired database name. In the first example below, we have selected theOracle database:
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In the second example below, we have selected theSQL Server database:

Connection Information - Databases
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1. See:"Databases" on page 81.
2. For the selected database, select and/or enter the required connection information. Depending upon the database selec-

ted, these settings could include:

• File ExtensionsSearched

• Password

• Search [Options]

• Hostname or IP

• Port Number

• Username

• Database

• Authorization Type

• SID or Service

• Schema

• Owner

• Classes

• DSN

• Instance Number

3. To have Find it EZ remember your password, click to check theRemember check-box.

4. Click on theApply button to apply your changes.

Test Database Connection

To test your connection, click on the Test Connection button.

1. If the test is unsuccessful, you will receive an "Connection failed!" message, along with a Reason. Check your settingsand
try again.

2. If the test is successful, you will receive a "A connection wasmade successfully!" message.

Note: The error handling systemwill provide up to twomessages/alerts:

• Find it EZ will indicate, in general, what happened (e.g. "Unable to connect.").

• The called programmay, at times, return amore detailedmessage that is proprietary to that target system and often
provides you with more details to help you resolve the "why" wewere unable to connect.We are not in control of the con-
tent of that message or when/if it comesback, but we will alwaysdisplay and log the extra detailswhenever possible.

Reset SearchDefaults

On the databaseConnection tab or report utilitiesOptions tab (see linksbelow), theSearch section contains a number of items for
which you can search. To select an item, click to check the preceding check-box.

To restore the selections to the default settings that camewith your Find it EZ install, click on theReset search defaults button.

OpenResults With

To specify the viewer/editor with which you want to open search results for the current database, locate theOpen Results With
field and click on the correspondingSelect Viewer/Editor button.

Apply Database Search Filters

Depending upon the database selected, youmaybe presented with a number of filter options fromwhich to choose, including:

• Data

• Tables
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• Stored Procedures

• Triggers

• User Defined Functions

• Views

• Java Procedures

• Functions

• Packages

• Events

Click on the desired filter tab (see linksbelow).

See Also: 
• "ApplyFile Filter" on page 77

• "Viewer / Editor Settings" on page 28

• "Report Utilities" on page 95

Search anOracle Database

1. From theSource frame on the left, locate the File Locations category.
2. Click to check the desired file location. TheProject Settings dialog will appear.

3. Configure settings. See Local or NetworkFolders example below:

4. From theSource frame on the left, click to checkOracle in theDatabases category.
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5. Configure settings. See example below:

6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.
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8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search. See
example below:

9. Once complete, theSearch Complete dialog boxwill appear.
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10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
example below:

Note: After performing a search, settings can be saved to a Project for later use again.

11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:
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Search a SQLServerDatabase

1. From theSource frame on the left, locate the File Locations category.
2. Click to check the desired file location. TheProject Settings dialog will appear.

3. Configure settings. See Local or NetworkFolders example below:

4. From theSource frame on the left, click to checkSQL Server in theDatabases category.



Search a SQL Server Database

© 2010 - 2016 Find it EZ Software Corp 89

5. Configure settings. See example below:

6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.
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8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search. See
example below:

9. Once complete, theSearch Complete dialog boxwill appear.
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10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
example below:

Note: After performing a search, settings can be saved to a Project for later use again.

11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:
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See Also:
• "Product Overview" on page 12

• "Set User Options" on page 21

• "Use the Expression Builder" on page 65

• "SearchingWindow" on page 68

• "WorkWith Search Results" on page 97

• "Save Search Results" on page 107

• "Include Source" on page 1

File Type
This section providesdetailed steps required to configure project settings for programming languages, documents, and report util-
ities.

Programming Languages
This section describes the procedures required to include the programming languages source in a search, add or remove file exten-
sions searched, and open resultswith the desired viewer/editor.

To accessproject settings for programming languages:

1. Edit the desired project.See: "Search Locationsand Source Settings" on page 75.

2. In the frame on the left, in the File Type category, locate theProgramming Languages sub category.

3. Click on the desired programming language. In the example below, we have selected theC Style (C,C++,C#) pro-
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gramming language:

AddorRemove File Extensions Searched

1. In the desired project, locate and select the source item for which you want to edit file extensions searched.

2. See one of the following:

• "Programming Languages" on the previouspage

• "Documents" on the next page

• "Report Utilities" on page 95

3. To add a file extension:

a. Click on theAdd button. A pop-up will appear.
b. Enter the name of the new file extension (without the leading ".").

c. Click on theOK button. The new file extension will be added to the File Extensions Searched list.
4. To remove a file extension:

a. In the File Extensions Searched list, click to select the file extension you want to remove.
b. Click on theRemove button. The selected file extension will be removed from the list.

5. To apply your changes to the selected source, click on theApply button.

See Also:
• "Include Source" on page 76

• "Open ResultsWith" on page 134
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Documents
This section describes the procedures required to include the documents source in a search, add or remove file extensions
searched, open resultswith the desired viewer/editor, and select Microsoft Excel search options (where applicable).

To accessproject settings for documents:

1. Edit the desired project.See: "Search Locationsand Source Settings" on page 75.

2. In the frame on the left, in the File Type category, locate theDocuments sub category.

3. Click on the desired document type. In the example below, we have selected theMicrosoft Excel document type:

Microsoft Excel SearchOptions

Note that when theMicrosoft Excel source is selected, you are able to select from the followingSearch options:

• Formulas

• Data

• Connection Properties

To include these items in the search, click to check the preceding check-box (un-check to exclude).

See Also:
• "Include Source" on page 76

• "Add or Remove File ExtensionsSearched" on the previouspage

• "Open ResultsWith" on page 134
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Report Utilities
This section describes the procedures required to include the report utilities source in a search, add or remove file extensions
searched, reset search defaults, download optional connectors, and open resultswith the desired viewer/editor.

To accessproject settings for report utilities:

1. Edit the desired project.See: "Search Locationsand Source Settings" on page 75.

2. In the frame on the left, in the File Type category, locate theReport Utilities sub category.

3. Click on the desired report utility. In the example below, we have selected theCrystal Reports report utility:

Note: TheUse default settings button resets the sectionsand search items to themost common used program set-
tings.

The steps required to configure project settings for a report utility are similar to other file type sources. Refer to the links below for
detailed instructions.

See Also:
• "Include Source" on page 76.

• "Download Connectors" on page 167

• "Add or Remove File ExtensionsSearched" on page 93

• "Reset Search Defaults" on page 134

• "Open ResultsWith" on page 134
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Reduce False PositiveMatches
** PLEASEPROVIDEYOURDEFINITIONOF FALSEPOSITIVEMATCHESHERE, AND LIST THEBENEFITSOF REDUCING
THEM.

False positivematches can be significantly reduced using the followingmethods:

See:
• "Exclude Files or Folders" on page 77

• "Select RepositoryFolders" on page 80

• "ApplyReport Filter" on page 80 and "ApplyFile Filter" on page 77; note that the latter instructionsalso apply to database
filters (data, tables, stored procedures, triggers, etc.).

• "Perform aRegular Search" on page 60; note the settingsavailable in theOptions section - Filters category.
• The following sourcesallow you to limit a search by selecting specificSearch data viaProject Settings: Databases,

Documents (Microsoft Excel), and Report Utilities. Click to select only those source locationsor data types that you need
to search. See linksbelow.
See Also:
• "Databases" on page 132

• "Documents" on page 94

• "Report Utilities" on the previouspage

• "Reset Search Defaults" on page 134
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WorkWith Search Results
This section describes the procedures required to view search results, statistics, and errors; to search within documents, to view
search result details; and to save, open, copy, modify, export, and print search results.

View Search Results
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. Resultsmatching your search criteria will be shown in theResultswindow. Use the horizontal scroll bar located below the
window to view all result data columns.

See Also:
• "View Result Statistics" on page 101

• "View Result Errors" on page 101

• "View Search Result Details" on page 101

ViewSearch Result History
To view previous (unsaved) search results:

Note: In order for theSearch Result History field to appear, youmust have completedmore than one search since the last
time you opened the Find it EZ program. This list of historical results is unlimited, but is automatically cleared when you exit the pro-
gram.

1. At the top of theResultswindow, click on theSearch Result History field. A drop-down list will appear, showing a list of
unsaved search result records tagged bydate and time.

2. Locate and click on the desired search result record. The corresponding search resultswill appear in theResultswindow
and will include anyannotationsor itemsmarked complete.

See Also:
• "Save Search Results" on page 107

ViewResult Source
Open Result

1. "View Search Results" above.

2. To open the result:

a. In theResultswindow, locate and double-click on the result for which you want to open the source.

OR

b. Right-click on the result and selectOpen Result from the context menu.

3. The result will open in the pre-selected viewer/editor depending upon the type.
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See Also: 
• "Viewer / Editor Settings" on page 28

Find it EZ Result Viewer
The Find it EZ Result Viewer allowsyou to view the source code for a search result document. This section describes the steps
required to open the viewer, change a location or group, navigate search results, find a file, and view or edit the source code in
another program.

OpenFind it EZResult Viewer

If "Find it EZ Viewer" is selected for the sourceCategory Default or By Source Item in "Viewer / Editor Settings" on page 28, then
when you "View Result Source" on the previouspage, it will appear in the Find it EZ Result Viewer. Text matching your search cri-
teria (i.e. matches) is highlighted in yellow.

Change Location orGroup

Groups in Find it EZ are locationswithin a document. For example, in PDF and CrystalReports there is a group for each page. Use
the Location/Group drop-down list to select the place in the document for which you want to view matches.

Navigate SearchResults

1. See: "Open Find it EZ Result Viewer" above
2. To navigate through thematches found in your document, click on the First,Next,Previous, or Last buttons located at the

top left of the viewer. Note that a counter to the right of the buttons keeps trackof whichmatch you are viewing; e.g. "Match 7
of 9."

Find in File

1. "Open Find it EZ Result Viewer" above

2. To search within the result document:

a. Enter the desired search text into the Find in File text box.
b. Click on the left arrow (find previous) or right arrow (find next) button. OR, press the [Enter] keyon your keyboard to

'find next.'

c. Itemsmatching your search criteria will be highlighted in blue. Click on the right arrow button or press [Enter] to nav-
igate through thematches found.

Documents withMultiple Tabs

The Find it EZResult Viewer for some documentswill contain multiple tabs. For an Excelworkbook, there is one tab per worksheet
(e.g.Sheet 1) plus a tab for workbookdetails (Workbook Info; including database connections, etc.). For other documents, you
normally only have a single tab with highlighted code. For SAPDashboards, thiswill contain aminimum of 3 tabs: Code viewer (Dash-
board code definition) +Excelworksheet +Excelworkbook info (connection/author). See example below.

Search, Results, and Details panel:
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To open the Find it EZResult Viewer, right-click on the workbook in theDetails panel and selectOpen from the context menu. Or,
double-click on the workbook.

Result Viewer Tabs:

Workbook Info tab:
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See Also:
• "Open ResultsWith" on page 134

• "Viewer / Editor Settings" on page 28

Select All Results or None
1. "View Search Results" on page 97.

2. In the header of the check-box column, click on the down arrow button. A context menu will appear.

3. To select all results:

• From themenu, chooseSelect - All. All resultswill be selected (checked).
4. To de-select all results:

• From themenu, chooseSelect - None. All check-boxeswill be cleared.

Search for All CheckedObjects
1. "View Search Results" on page 97.

2. In the check-box column, click to select (check) the result objects for which you want to search your project for references.

3. In the header of the check-box column, click on the down arrow button. A context menu will appear.

4. From themenu, selectSearch for all checked objects. AContinue notificationmessage will appear.

5. To launch the search, click on theOK button. The search will proceed, and any resultswill appear in theResultswindow.

OR

6. To cancel, click on theCancel button.

See Also: 
• "Select AllResults or None" above

• "Save Search Results" on page 107
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Open Viewer and Editor Settings
To accessproject settings from theResultswindow:

1. "View Search Results" on page 97.

2. In theResultswindow, right-click on any result. A context menu will appear.
3. From themenu, click to selectSettings. TheConfigure Viewer/Editor Settings pop-up will appear.

See Also:
• "Viewer / Editor Settings" on page 28r"Viewer / Editor Settings" on page 28

• "Open ResultsWith" on page 134

Search Within Result Documents
1. "View Search Results" on page 97.

2. At the top of theResultswindow, click to check theSearch within Documents check-box.

3. On the search bar, enter the desired search text into the Find text box.
4. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search.
5. Once complete, theSearch Complete dialog boxwill appear.
6. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame.

View Result Statistics
1. "View Search Results" on page 97.

2. In theResultswindow, click on theStatistics tab. Use the horizontal scroll bar located at the bottom of the window to view
all data columns; Location, Type, Documents, Matches.

View Result Errors
1. "View Search Results" on page 97.

2. In theResultswindow, click on theErrors tab. Use the horizontal scroll bar located at the bottom of the window to view all
data columns; Location, Type, Host, File Path or Database, Document.

View Search Result Details
1. "View Search Results" on page 97.

2. In theResultswindow, click on the result for which you want to view details.
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The image below has theShow matches only option checked:

• Detailswill appear in theDetailswindow located below theResultswindow.
• Detailswill be grouped by source (e.g. Code, Document, etc.) and a context line will be shown for eachmatch instance. See

first image above.

• Matchesare highlighted in each line where theyappear, and linesare numbered.

• To view only those lineswith amatch, click to check theShow matches only check-box. See second image above. Note
that the line numbersare hidden when this option is checked.
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• To searchDetails, enter your search text into the text boxand click on the First,Next,Previous, Last, or arrow buttons.

• To open the Find it EZ Result Viewer, right-click inside theDetails panel and selectOpen from the context menu. You can
alsoSelect All andCopy using the samemethod.

• TheShow matches only option is auto-synchronized to theAutomatically expand details user option (see link below).
When turned on, you will see the full context of the searched document with line numbers.When turned off, only lineswith
matcheswill appear (without line numbers).

ViewSource via Result Details
1. "View Search Result Details" on page 101.

2. Right-click on the selected result detail and selectOpen from the context menu.

3. Thematching result will open in the selected viewer/editor. If using the Find it EZResult Viewer:
• The text matching the search criteria for the selected instance will be highlighted in blue

• All other instancesmatching the search criteria will be highlighted in yellow

Copy Detail Item to Clipboard
1. "View Search Result Details" on page 101.

2. Locate thematching instance line that you want to copy to the clipboard.

3. Right-click on the selected line. A context menu will appear.

4. From themenu, selectCopy. The selected line will be copied to the clipboard.
5. Paste the copied text to the desired location.

See Also:
• "Set User Options" on page 1

• "Viewer / Editor Settings" on page 28

• "Find it EZ Result Viewer" on page 98

Copy Search Results
This section describes the steps required to copyan object name to the clipboard, add an object name to the Boolean search term, or
replace the Boolean search term.

CopyObject Name to Clipboard
1. "View Search Results" on page 97.

2. In theResults list, locate the file of which you want to copy the object name to the clipboard.
3. Right-click on the file. A context menu will appear.

4. From themenu, selectCopy Object Name. The name of the selected file object will be added to the clipboard.
5. Paste the object name to the desired location.

AddObject Name to Boolean Search Term
1. "View Search Results" on page 97.

2. In theResults list, locate the file of which you want to add the object name to the Boolean search term.
3. Right-click on the file. A context menu will appear.
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4. From themenu, selectAdd to Boolean Term (OR)ORAdd to Boolean Term (AND), as desired. The name of the
selected file object will be appended to anyexisting search term in the Find text box (on the search bar).

Replace Boolean Search Term
1. "View Search Results" on page 97.

2. In theResults list, locate the file having the object namewith which you want to replace the Boolean search term.
3. Right-click on the file. A context menu will appear.

4. From themenu, selectReplace Search Term .The name of the selected file object will replace anyexisting search term in
the Find text box (on the search bar).

See Also: 
• "Find it EZ CustomBoolean Syntax" on page 66

Modify Search Results
This section provides step-by-step instructions tomark search result itemscomplete or incomplete, add or edit result annotations,
remove an item(s) from search results, and to add a file to a project's search exclusion list.

Mark Item(s) Complete or Incomplete
1. "View Search Results" on page 97.

2. In theResultswindow, locate the result you want to mark complete or incomplete.
3. Right-click on the result row. A context menu will appear.

4. Click to selectMark Completed orMark Incomplete, as desired.
• If marked complete, a green check-markwill appear preceding the result.

• If a completed result is thenmarked incomplete, the green check-markwill be removed.

Mark All Complete or Incomplete
1. "View Search Results" on page 97.

2. In the check-box column, click to select the results you want to mark complete or incomplete.

3. In the header of the check-box column, click on the down arrow button. A context menu will appear.

4. Tomark the selected results complete, selectMark all checked as completed from themenu.

OR

5. Tomark the selected results incomplete, selectMark all checked as incomplete from themenu.

Note: If any search results have beenmarked complete and you attempt the exit/close the programwithout first saving
your results, you will be prompted to save your search results, continue without saving, or keep the program open.

Select All Items Marked Completed
To locate all results that have beenmarked completed:

1. "View Search Results" on page 97.

2. In the header of the check-box column, click on the down arrow button. A context menu will appear.

3. From themenu, chooseSelect - items marked completed. All results previouslymarked completed will be selected
(checked).
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See Also: 
• "Select AllResults or None" on page 100

• "Save Search Results" on page 107

Add or Edit Annotations
This section outlines the procedures required to add, view, edit, or delete an annotation or to locate and select all itemswith annota-
tions.

Add Annotation
1. "View Search Results" on page 97

2. In theResultswindow, locate the result to which you want to add an annotation.
3. Right-click on the result row. A context menu will appear.

4. From themenu, selectAnnotations. AnAdd/Edit Annotations pop-up will appear.
5. Click on theAdd Newbutton. A new entrywill be added, including the current date, time (in theDate field), and username

(in theEntered by field).
6. In theComments text box, enter the desired annotation.

7. Click on theSave button to save your note and close theAdd/Edit Annotations pop-up. A clipboard icon will appear in the
Resultswindow preceding each result with an annotation.

Note: If any search results have annotationsand you attempt the exit/close the programwithout first saving your results,
you will be prompted to save your search results, continue without saving, or keep the program open.

8. To discard any changes, click on theCancel button.

View Annotations
1. "View Search Results" on page 97

2. In theResultswindow, locate the result for which you want to view annotations.

Note: Resultswith annotationsare preceded bya clipboard icon.

3. Right-click on the result row. A context menu will appear.

4. From themenu, selectAnnotations. AnAdd/Edit Annotations pop-up will appear. Details for themost recent annota-
tion will be shown bydefault in the lower section of the pop-up. To view another annotation, click to select the desired row
(e.g. byDate or Entered by) from the list in the upper section.

Edit Annotation
1. See:"View Annotations" above.

2. For the selected annotation, make the desired changes in theComments text box.
3. Click on theSave button to save. A new, dated entrywill be generated to include the changes.
4. To discard your changes, click on theCancel button.

Delete Annotation
1. "View Annotations" above

2. In the list of annotations, click to select the entry you want to delete.
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3. Click on theDelete button. The selected annotation will be removed from the list.

4. To close theAdd/Edit Annotations pop-up, click on theX button.

Select All Items with Annotations
1. "View Search Results" on page 97.

2. In the header of the check-box column, click on the down arrow button. A context menu will appear.

3. From themenu, chooseSelect - items with annotations. All resultswith annotationswill be selected (checked).

See Also: 
• "Save Search Results" on the facing page

Remove Item from Search Results
1. "View Search Results" on page 97

2. In theResultswindow, locate the result you want to remove from the list.

3. Right-click on the result row. A context menu will appear.

4. From themenu, selectRemove. AnAre you sure? confirmationmessage will appear.

Tip: To prevent this pop-up from appearing the next time you remove a result, click to check theDo not ask again
check-box.

5. To remove the selected item from the search results, click on theYes button.

OR

6. To cancel, click on theNo button.

Remove All Checked Results
1. "View Search Results" on page 97.

2. In the check-box column, click to select (check) the results you want to remove.

3. In the header of the check-box column, click on the down arrow button. A context menu will appear.

4. From themenu, selectRemove all checked. AnAre you sure? confirmationmessage will appear.

Tip: To prevent this pop-up from appearing the next time you remove a result, click to check theDo not ask again
check-box.

5. To remove the selected items from the search results, click on theYes button.

OR

6. To cancel, click on theNo button.

See Also:
• "Remove Item fromSearch Results" above
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Add File(s) to Project Search Exclusion List
Add a Single File to the Project Exclusion List

Note: This option is available only for results sourced from Local or NetworkFolders.

Purpose: If one or more files come up in theResultswindow Errors tab list, and (for example) the file is corrupt, can't be opened, or
is on theResults list and you know you don't want to include this particular file in future search passes for this project's Local or Net-
workFolders files, you can use this option to add it to the project file exclusion list quickly and easily, as follows:

1. "View Search Results" on page 97.

2. In theResults list, locate the file that you want to add to the current project's search exclusion list.
3. Right-click on the file. A context menu will appear.

4. From themenu, selectAdd file to project exclusion list. The selected file will be added to theExclude File(s) / Folder
(s) list inProject Settings for Local or NetworkFolders.

Add Multiple Files to Project Exclusion List
1. In theResults list, locate the files that you want to add to the current project's search exclusion list.

2. In the check-box column, click to select (check) the desired results.

3. In the header of the check-box column, click on the down arrow button. A context menu will appear.

4. From themenu, selectAdd selected files to project exclusion list. The selected fileswill be added to theExclude File
(s) / Folder(s) list inProject Settings for Local or NetworkFolders.

Remove an Item From the Project Exclusion List

See: "Exclude Files or Folders" on page 77

Save Search Results
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Save. ASave Search Results dialog boxwill appear.

3. In theName text box, enter a descriptive name for the results.

Alert: Database table data search resultswill not be saved.

4. Click on theSave button.

Note: Once you save search results, every subsequent change to the search results elements are automatically re-
saved. Also, If any search results have annotationsor have beenmarked complete and you attempt the exit/close the pro-
gramwithout first saving your results, you will be prompted to save your search results, continue without saving, or keep
the program open.
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Open Saved Search Results
1. From the Find it EZ menu, select File -> Open. AnOpen Search Results dialog boxwill appear.

2. From theSearch drop-down list, select the name of the saved search results.

Note:Once saved results are opened, all further changes to them are automatically saved (this is reset when you exit the
programOR if you run another search to replace the "SAVED / re-Opened" search results that you had been working
with. Also, when you open a previously saved search result, this also auto-switches to the saved Project settings. The
saved results listed include the following identifiers: Date, Time, [File] Name, Project Name, Search Type, and Search
text.

3. Click on theOpen button. The selected search resultswill appear in theResultswindow.

See Also:
• "Add or Edit Annotations" on page 105

• "Mark Item(s) Complete or Incomplete" on page 104

Export Results
Follow these instructions to export search results/result details, MSProject tasks, or an error list.

Export Search Results
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Export -> Search Results List. ASelect the items to include pop-up will
appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. ASave As dialog boxwill appear.

i. Navigate to the destination folder.

ii. Enter the desired File name.
iii. Click on theSave button.

c. ASave Complete pop-up will appear.

i. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

ii. To close theSave Complete pop-up, click on theClose button.
3. Exported search resultswill contain the following data columns:

• Source Location
• File Type
• Host Name
• File Path or Database
• Document Name
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• Number ofMatches
• Annotations

Export Search Result Details
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. To export selected details only:

a. In theResultswindow, click on a result row. Detailswill appear in theDetailswindow.
3. From the Find it EZ menu, select File -> Export -> Search Results Detail. ASelect the items to include pop-up will

appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. ASave As dialog boxwill appear.

i. Navigate to the destination folder.

ii. Enter the desired File name.
iii. Click on theSave button.

c. ASave Complete pop-up will appear.

i. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

ii. To close theSave Complete pop-up, click on theClose button.
4. Exported search results detail will contain the following data columns:

• Source Location
• File Type
• Host Name
• File Path or Database
• Document Name
• Section
• Search Terms Matched
• Matches Found
• Original Line

Export MSProject Tasks
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Export -> MS Project Tasks. ASelect the items to include pop-up will
appear.
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a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. ASave As dialog boxwill appear.

i. Navigate to the destination folder.

ii. Enter the desired File name.
iii. Click on theSave button.

c. ASave Complete pop-up will appear.

i. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

ii. To close theSave Complete pop-up, click on theClose button.
3. Exported search resultswill contain the following data columns:

• Active - Yesor No
• Task_Mode - Auto Scheduled or ManuallyScheduled
• Task_Name - Search Source and Path
• Notes - Host and Path

Import Tasks toMicrosoft Project
1. See "Export MSProject Tasks" above.

2. OpenMicrosoft Project.

3. From the Filemenu, selectNew.
4. On theNewpage, clickNew from Excel workbook.

5. In theOpen box, click the arrow next toXML Format, and pickExcel Workbook.

6. Locate and select the workbook you want to import, and clickOpen.

7. In the Import Wizard, clickNext to get started, and follow the steps to complete the import.

Export Error List
1. Perform a search:

• See: "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. If anyerrors are generated during the search, theErrors tab in theResultswindow will be selected automatically, the total
number of errorswill be shown on the tab label, and error detailswill be listed.

3. From the Find it EZ menu, select File -> Export -> Error List. ASave As dialog boxwill appear.
a. Navigate to the destination folder.

b. Enter the desired File name.
c. Click on theSave button.

4. ASave Complete pop-up will appear.

a. To view the saved file, click on theView Nowbutton. The file will open in the selected viewer (see below).

Tip: Click to check theAlways view, do not show again check-box to always view the saved results file.

b. To close theSave Complete pop-up, click on theClose button.
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5. The exported error list will contain the following data columns:

• Location
• Type
• Host
• File Path or Database
• Document
• Error
• Details

See Also:
• "WorkWith Search Results" on page 97

• "Viewer / Editor Settings" on page 28

• "Set User Options" on page 1

Print Results
Follow these instructions to print search results or search result details.

Print Search Results
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Print -> Search Results List. ASelect the items to include pop-up will
appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. A report containing the selected resultswill open in a new browser window and a browser

Print dialog will be launched.
3. Select theDestination and configure print settings, asdesired.
4. Click on thePrint button. The report will be sent to the selected destination printer or file.
5. The generated report will contain the following data:

Header:

• Date Created
• Search Type
• Search Options
• Search Expression
• Search Locations

Columns:

• Source Location
• File Type
• Host Name
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• FilePath or DB (Database)

• Object Name
• # Found (Matches)

Print Search Result Details
1. Perform a search:

• "SearchWizard" on page 31

• "Perform aRegular Search" on page 60

• "Use the Expression Builder" on page 65

2. From the Find it EZ menu, select File -> Print -> Search Results Detail. ASelect the items to include pop-up will
appear.

a. Click to choose one of the options;All results,Currently displayed results, or Checked results only.
b. Click on theNext button. A report containing the selected resultswill open in a new browser window and a browser

Print dialog will be launched.
3. Select theDestination and configure print settings, asdesired.
4. Click on thePrint button. The report will be sent to the selected destination printer or file.
5. The generated report will contain the following data:

Report header:

• Date Created
• Search Type
• Search Options
• Search Expression
• Search Locations
• Search Category

Header for eachmatch found:

• Source Location
• File Type
• Host Name
• Filepath or DB (Database)

• Object Name
• # Matches

See Also:
• "WorkWith Search Results" on page 97
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Compare Files, Reports, andDatabases
Refer to this section for step-by-step instructions required to start or modify a comparison, show differences, filter/search/export com-
pare results, view compare result details, expand/collapse compare results, compare status colours, find in source or target, show dif-
ferencesonly, export compare details, and copyor print compare results.

View Compare Results Detail
See:"CompareWizard" on page 42.

After completing a comparison using theCompare Wizard and viewing the results summary, click on the Finish button to view the
Comparison Resultswindow. See example below:

Start New Compare
1. "View Compare ResultsDetail" above.

2. In the upper, left corner of theComparison Resultswindow, click on the button. You will be returned to theCom-
pare Wizard to start a new comparison.

Modify Current Compare
1. "View Compare ResultsDetail" above.

2. In the upper, left corner of theComparison Resultswindow, click on the button. You will be returned to theCom-
pare Wizard to select which documents you want to compare.

Show Differences
See:"CompareWizard" on page 42.
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At the top of theComparison Resultswindow, there are a number ofShow Differences view filters available. See below:

Click to check the desired check-box to view that selection. The first three filters are checked bydefault. Click to un-checkanyas
desired:

• Only in Source
• Only in Target
• Different

To view comparison results that arematching, click to check the Identical check-box.

Filter or Search Compare Results
1. At the top of theComparison Resultswindow, locate the Filter text box.
2. Enter the desired filter/search text into the text box. The results list will update automatically to show only those resultsmatch-

ing your specified criteria.

Export Compare Results
See: "CompareWizard" on page 42.

1. "Filter or Search Compare Results" above.

2. At the top of theComparison Resultswindow, locate and click on theExport List button. ASave As dialog will appear.
3. Enter a File name.

4. Click on theSave button.

Note: The list will be saved in *.xlsx file format.

5. The saved list will open automaticallywith the selected viewer/editor.

6. The following data will be included in the exported file:

• Source, Target, and Date Created

• View filter(s)

• Type

• # Differences

• Document

• Source Host

• Source File Path or Database

• Target Host

• Target File Path or Database

• Compared To

7. Save the file asdesired.
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Expand or Collapse Compare Results
In the results list on theComparison Resultswindow, results are grouped bydocument and document type. To expand or collapse
a result group, click on the '+' or '-' button, respectively.

Compare Status Colours
See: "CompareWizard" on page 42.

At the bottom of theComparison Resultswindow, there is a result status colour key. See below:

Differencesbetween the source and target content are highlighted in the above colours.

To show differencesonly, click to check theShow differences only check-box.

Find in Source or Target
1. At the top of theSource or Target window, locate the Find text box.
2. Enter the desired filter/search text into the text box.

3. Click on the right arrow button to find next or the left arrow button to find previous. Content matching your search criteria will
be highlighted in purple.

4. Repeat to view all instancesmatching your search criteria.

Show Differences Only
To view only the differences in content between the source and target, click to check theShow differences only check-box.

Export Compare Details
At the bottom right of theComparison Resultswindow, locate and click on either theHTML or Excel button. Source and target
detailswill open in the selected editor. Save asdesired.

See Also:
• "CompareWizard" on page 42

• "Select Documents to Compare" on page 1

• "Viewer / Editor Settings" on page 28
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Copy or Print Compare Results
Select All Source or Target Compare Results

1. In the compare results list at the top, click to highlight the document for which you want to view details. Detailswill appear in
theSource and Target boxesat the bottom.

2. In theSource or Target box, right-click on the compare result details. A context menu will appear.
3. From the context menu, chooseSelect All. All details in the current boxwill be highlighted.

Copy Source or Target Compare Results
1. In the compare results list at the top, click to highlight the document for which you want to view details. Detailswill appear in

theSource and Target boxesat the bottom.
2. In theSource or Target box, select the text you want to copy.
3. Right-click on the compare result details. A context menu will appear.

4. From the context menu, selectCopy. All highlighted details in the current boxwill be copied to the clipboard.

Save or Print Source or Target Compare Results
1. In the compare results list at the top, click to highlight the document for which you want to view details. Detailswill appear in

theSource and Target boxesat the bottom.
2. In theSource or Target box, right-click on the compare result details. A context menu will appear.
3. From the context menu, selectPrint. ASave As dialog will appear.
4. Enter a File name and click on theSave button. The document will open in a new browser tab.

5. Print as desired; press the [Ctrl] + [P] keyson your keyboard.

See Also:
• "CompareWizard" on page 42
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Search and Replace
This section provides the instructions required to replace CrystalReports data source connectionsor qualified table namesor BOE
BI database logon information.

Crystal Reports
Data Source Connections or Qualified Table Names
Follow these steps:

1. "Launch the ReplaceWizard" on page 54.

2. "SelectWhere to Look for Reports" on page 54.

3. "Select Report Destination Folder" on page 55.

4. "Select Report Tables to Change" on page 56.

5. "Choose New Connection Type" on page 57.

6. "Confirm Information and Replace" on page 58.

BOEBI Database Logon Information
See: "ReplaceWizard" on page 54.
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Built-in Reports andDocumentation
This section describes the steps required to access variousFind it EZ reports included with the system.

For example, if you wanted to analyse a large number of historic version reports in preparation for a possible upgrade to find which
onesuse non-ansi outer join syntax in the queries, you could do the following:

ManyFind it EZ reportswill give you preciselywhat you are looking for. One is the "Show SQLQueries" report. This report extracts
any joins used by the visual linking expert within the CR designer and recreates the SQL code based on the join property optionsused
by the visual linking tool. There is also the "Report Definition" and "SQLCode Extract" which actually hasa column or section showing
the type of join used when applicable via the visual linking expert. These reports are available under theReports -> Business Intel-
ligencemenu.

Note: Our trialmode has the number of documents searched and output limited. However, a fully unlocked version is not limited.
Thismayaffect your evaluation results if the limits are hit prior to processing a file that contains visual linking.

Business Intelligence Reports
BI Reports can be generated and accessed as follows:

From themenu, selectDocument -> Business Intelligence -> [desired report]. See below.

The following business intelligence reports are available:

• SQLCode Extract

• ReportsDefinition

• Show SQLQueries

• Database Cross-Reference

• Report Listing

SAP BOE Crystal Server
SAPBOE / Crystal Server reports can be generated and accessed as follows:

From themenu, selectDocument -> SAP BOE / Crystal Server-> [desired report]. See below.

The following SAPBOE / Crystal Server reports are available:

• Report Schedules

• Security Listing

Migrating Reports Example
The oldest Crystal Server supported by the vendor supplied XI 3.1 connector isCRS2008. Adding support for versionsearlier then
that requiresolder SDKsno longer supported or available from SAP ( we are a Partner and can't get those old SDKsunfortunately ).

There is a simplified procedure. Provided you do not need to convert and continue to use the reportswithin your existing Crystal XI
(11) server, here iswhat you can do:

1. Download the RPT files from your CR XI server, saving the files locally. Unfortunately, it doesnot look like there is amass
download function built into the Crystal Server CMS.
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2. Start Find it EZ DevSurge 365. Change the "repository" within Find it EZ:.

a. From themenu, select Tools -> Customize -> File Locations.
b. From the SAPRepository drop-down list, select Crystal Server 2013.

c. Click on theOK button. Thismay force a program restart, this is normal.

3. Install the latest BI 4.1 SP7 connector. Use thismenu and follow-directions to download and install automatically:

a. From themenu, select Tools -> Download Connectors -> BusinessObjects BI Platform.
b. Click on theDownload & Install button.

4. Use the change datasource wizard to automatically change the datasource and upgrade the RPT files to CR 2013 format
(bydefault, saved files are now also in CR 2013 format). No need to open and save each RPT file individually using CR
Designer 2013.

a. From themenu, selectReplace -> Crystal Reports -> Data source connections or qualified table names.
5. Use the normalCR 2013 upload exe to place all the converted RPT files into the new target CRS2013 repository.

6. If necessary after upload, you can also use Find it EZ to set / reset login authentication on all uploaded RPT fileswithin the
new CRS2013 repository.

a. From themenu, selectReplace -> Crystal Reports -> BOE BI Database logon information.

Save and View Report
When you generate a report using theExport Wizard, aSave As dialog appears. Enter a File name and click on theSave button.
The report is created and aSave Complete notification appears. To view the saved report, click on theView Nowbutton. The
report will open in the selected editor.

See Also:
• "DocumentWizard" on page 50

• "Navigation" on page 13

• "Viewer / Editor Settings" on page 1
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ExampleWorkflow Scenarios
This section providesa number of example scenarios, procedures, and resulting screen shots for searching and reporting in source
file locations, databases, and accessing reporting tools.

Source File Locations
Examplesprovided in this section include searching local or network folders, searching aGitHub repository, and searching a Team
Foundation Server (TFS) repository.

Search Local or Network Folders
1. From theSource frame on the left, locate the File Locations category.
2. Click to check the Local or Network Folders source. TheProject Settings dialog will appear.

3. Configure settings.See:"Local or NetworkFolders" on page 75

4. From theSource frame on the left, click to checkone or more supported file type(s). For example, select a file type from the
Documents category.
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5. Configure settings. See example below:

6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.
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8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search.

9. Once complete, theSearch Complete dialog boxwill appear.
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10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame.

Note: After performing a search, settings can be saved to a Project for later use again.
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11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:

Search aGit / GitHub Repository
1. From theSource frame on the left, locate the File Locations category.
2. Click to check theGit / GitHub source. TheProject Settings dialog will appear.

3. Configure settings.See: "Connection Information - Repositories" on page 79. See example below:
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4. From theSource frame on the left, click to checkone or more supported file type(s). In the example below,C Style
(C,C++,C#) hasbeen selected from theProgramming Languages category.

5. Configure settings. See example below:

6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.
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8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search. See
example below:

9. Once complete, theSearch Complete dialog boxwill appear.
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10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
example below:

Note: After performing a search, settings can be saved to a Project for later use again.

11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:
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Search a Team Foundation Server (TFS) Repository
1. From theSource frame on the left, locate the File Locations category.
2. Click to check the Team Foundation Server source. TheProject Settings dialog will appear.

3. Configure settings.See: "Connection Information - Repositories" on page 79. See example below:

4. From theSource frame on the left, click to checkone or more supported file type(s). In the example below,C Style
(C,C++,C#) hasbeen selected from theProgramming Languages category.
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5. Configure settings. See example below:

6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.
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8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search. See
example below:

9. Once complete, theSearch Complete dialog boxwill appear.
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10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
example below:

Note: After performing a search, settings can be saved to a Project for later use again.

11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:
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See Also:
• "Product Overview" on page 12

• "Set User Options" on page 21

• "Use the Expression Builder" on page 65

• "SearchingWindow" on page 68

• "WorkWith Search Results" on page 97

• "Save Search Results" on page 107

Databases
This section describes the procedures required to include the databases source in a search, enter database connection information,
test a database connection, reset search defaults, open resultswith the desired viewer/editor, and apply variousdatabase search fil-
ters.

To accessproject settings for databases:

1. Edit the desired project.See: "Search Locationsand Source Settings" on page 75.

2. In the frame on the left, in the Location category, locate theDatabases sub category.

3. Click on the desired database name. In the first example below, we have selected theOracle database:
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In the second example below, we have selected theSQL Server database:
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Connection Information - Databases
1. See:"Databases" on page 132.
2. For the selected database, select and/or enter the required connection information. Depending upon the database selec-

ted, these settings could include:

• File ExtensionsSearched

• Password

• Search [Options]

• Hostname or IP

• Port Number

• Username

• Database

• Authorization Type

• SID or Service

• Schema

• Owner

• Classes

• DSN

• Instance Number

3. To have Find it EZ remember your password, click to check theRemember check-box.

4. Click on theApply button to apply your changes.

Test Database Connection
To test your connection, click on the Test Connection button.

1. If the test is unsuccessful, you will receive an "Connection failed!" message, along with a Reason. Check your settingsand
try again.

2. If the test is successful, you will receive a "A connection wasmade successfully!" message.

Note: The error handling systemwill provide up to twomessages/alerts:

• Find it EZ will indicate, in general, what happened (e.g. "Unable to connect.").

• The called programmay, at times, return amore detailedmessage that is proprietary to that target system and often
provides you with more details to help you resolve the "why" wewere unable to connect.We are not in control of the con-
tent of that message or when/if it comesback, but we will alwaysdisplay and log the extra detailswhenever possible.

Reset Search Defaults
On the databaseConnection tab or report utilitiesOptions tab (see linksbelow), theSearch section contains a number of items for
which you can search. To select an item, click to check the preceding check-box.

To restore the selections to the default settings that camewith your Find it EZ install, click on theReset search defaults button.

OpenResultsWith
To specify the viewer/editor with which you want to open search results for the current database, locate theOpen Results With
field and click on the correspondingSelect Viewer/Editor button.
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Apply Database Search Filters
Depending upon the database selected, youmaybe presented with a number of filter options fromwhich to choose, including:

• Data

• Tables

• Stored Procedures

• Triggers

• User Defined Functions

• Views

• Java Procedures

• Functions

• Packages

• Events

Click on the desired filter tab (see linksbelow).

See Also: 
• "ApplyFile Filter" on page 77

• "Viewer / Editor Settings" on page 28

• "Report Utilities" on page 95

Search anOracle Database
1. From theSource frame on the left, locate the File Locations category.
2. Click to check the desired file location. TheProject Settings dialog will appear.

3. Configure settings. See Local or NetworkFolders example below:
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4. From theSource frame on the left, click to checkOracle in theDatabases category.

5. Configure settings. See example below:
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6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.

8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search. See
example below:
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9. Once complete, theSearch Complete dialog boxwill appear.

10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
example below:
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Note: After performing a search, settings can be saved to a Project for later use again.

11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:

Search a SQL Server Database
1. From theSource frame on the left, locate the File Locations category.
2. Click to check the desired file location. TheProject Settings dialog will appear.

3. Configure settings. See Local or NetworkFolders example below:
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4. From theSource frame on the left, click to checkSQL Server in theDatabases category.

5. Configure settings. See example below:
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6. From theOptions frame on the right, choose the desiredSearch Type andScope, and select the desired Filters.

Note: Default searchOptions are:Search Type =Boolean Search,Scope =Search Entire Document, Filters =
None. Search options can be changed for 'on start-up' or 'new project' search to use this default or to remember your last
used settings.

Tip: For better search performance, click to check the Use pre-indexed documents in Filters. Thiswill use the last
indexed document content and therefore will not refresh content with latest updates. Use this filter if it is known that the
source documents are changed infrequently or have not changed since the last Find it EZ project indexing.

7. On the search bar (see image below), enter the desired search text into the Find text box.

8. Click on theSearch button to initiate the search. ASearching dialog boxwill appear, showing the statusof the search. See
example below:
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9. Once complete, theSearch Complete dialog boxwill appear.

10. Click on theShow Results button. A list of resultsmatching your search criteria will appear in theResults frame. See
example below:
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Note: After performing a search, settings can be saved to a Project for later use again.

11. To view details for a result, click on a row in theResultswindow. Detailswill appear in theDetailswindow.

12. To view the source file, right-click on a detail line and selectOpen from the context menu. See example below:

See Also:
• "Product Overview" on page 12

• "Set User Options" on page 21

• "Use the Expression Builder" on page 65

• "SearchingWindow" on page 68
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• "WorkWith Search Results" on page 97

• "Save Search Results" on page 107

• "Include Source" on page 1

Reporting Tools
Examples in this section include creating a SQL statements detail extract and creating a database cross-reference list.

Create a SQL Statements Detail Extract
1. Launch the ExportWizard for SQL Code Extract:

a. Using the SearchWizard:

i. At the top, left of themain window, click on theSearch Wizard button. TheSearch Wizard dialog will appear.
ii. Click to choose theExtract database objects (tables, stored procedures, views, etc.) used in my

reports option. TheExport Wizard will appear.
b. Using themenu:

i. From the Find it EZ menu, selectDocument -> Business Intelligence -> SQL Code Extract. TheExport
Wizard will appear. See below:

2. See: "Create or Select a Project" on page 35.

3. Click on theNext >>button to continue.
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4. Click to select the file types to include. See: "Select File Types to Include" on page 36.

5. Click on theNext >>button to continue.
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6. Click to select the desired search locations. See: "Select Search Location(s)" on page 37.

7. Click on theNext >>button to continue.
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8. Enter the file location connection information. See:

• "Add or Edit Search Path(s)" on page 76

• "ApplyFile Filter" on page 77

• "Include Archive Files" on page 77

9. Click on theNext >>button to continue. TheProject Settings dialog will appear.
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10. Enter connection settings for the selected source. See:

• "Connection Information - Databases" on page 134

• "Connection Information - Repositories" on page 79

11. Click on theNext >>button to continue.



Create a SQL StatementsDetail Extract

© 2010 - 2016 Find it EZ Software Corp 149

12. Choose report options. See: "Choose Report Optionsand Export Report" on page 52.

13. Click on theExport button. Find it EZ will begin gathering the required data.

14. Once complete, aSave As dialog will appear. See example below:
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15. Save the report:

a. Modify the File name asdesired.
b. Navigate to the desired folder location.

c. Click on theSave button.

ASave Complete notiification will appear, as below:

16. To view the saved report, click on theView Nowbutton. The file will open in the specified viewer/editor. See example below:

Report data will include the following:
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• Location

• Type

• Host

• File Path

• Filename

• Report Section

• Data Source Type

• Data Source Name

• Database

• Owner

• Report Table

• Call Statement

• Table Links

• SQL Command

• SQL Expressions

• Underlying Database Code

Create a Database Cross-Reference List
1. Launch the ExportWizard for Database Cross-Reference:

a. Using the SearchWizard:

i. At the top, left of themain window, click on theSearch Wizard button. TheSearch Wizard dialog will appear.
ii. Click to choose theCreate a database cross-reference for my reports option. TheExport Wizard will

appear.

b. Using themenu:

i. From the Find it EZ menu, selectDocument -> Business Intelligence -> Database Cross-Reference.
TheExport Wizard will appear. See below:
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2. See: "Create or Select a Project" on page 35.

3. Click on theNext >>button to continue.
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4. Click to select the file types to include. See: "Select File Types to Include" on page 36.

5. Click on theNext >>button to continue.
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6. Click to select the desired search locations. See: "Select Search Location(s)" on page 37.

7. Click on theNext >>button to continue.
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8. Enter the file location connection information. See:

• "Add or Edit Search Path(s)" on page 76

• "ApplyFile Filter" on page 77

• "Include Archive Files" on page 77

9. Click on theNext >>button to continue.
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10. Choose report options. See: "Choose Report Optionsand Export Report" on page 52.

11. Click on theExport button. Find it EZ will begin gathering the required data.

12. Once complete, aSave As dialog will appear. See example below:
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13. Save the report:

a. Modify the File name asdesired.
b. Navigate to the desired folder location.

c. Click on theSave button.

ASave Complete notiification will appear, as below:

14. To view the saved report, click on theView Nowbutton. The file will open in the specified viewer/editor. See example below:

Report data will include the following:
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• Location

• Host

• File Path

• Filename

• Sub Report

• Section

• Data Source Type

• Data Source Name

• Database

• Schema/Owner

• Report Table

• Column

• Detail

See Also:
• "Navigation" on page 13

• "Search Locationsand Source Settings" on page 75

• "SearchingWindow" on page 68

• "Set User Options" on page 21

• "Viewer / Editor Settings" on page 28
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Troubleshooting
This section will provide solutions to someworkstation and environmental issues.

Identify reports using a specified connection
Youmay, for example, want to try to determine if there are CrystalReportsmaking anODBC connection to certain environments.
Here's how you can do it using Find it EZ:

There are a couple of ways you can do this.

Ensure that searching connection information is enabled in the CrystalReport settings:

• In theSourcePanel in theReport Utilities section, click to check the CrystalReports source
• Click to check the Include Crystal Reports check-box
• Open the CrystalReports project settings: from themenu, selectProjects -> Settings -> Crystal Reports
• In theSearch section, click to check theData Source and Connections option

Then,

• (A) Good - Do a Boolean search for {ODBC} AND {DSN}; where DSN is your DSN. That should find all of the reportswith
that connection.

• (B) Best - Generate the "SQLCode Extract" Report which will list all of the connectionsused in your reports. You can then fil-
ter and sort the spreadsheet to those using ODBC and a certain connection.

Note: We cannot "follow the link" so to speak.Where a report is using anODBC connection called PRODUCTION and that is
pointing to dblive01, we will not be able to show you dblive01.

See Also:
• "Perform aRegular Search" on page 60

• "Create a SQL StatementsDetail Extract" on page 144

Program freezes when attempting to index Crystal
Reports on a local or network file system
Solution:

1. From themenu, select Tools -> Customize -> User Options.
2. In thePerformance section, click to check theEnable Crystal Report locked file pre-checked (Local or network

folders only) option.

This allows the CrystalReports scanner to detect locked files during indexing and, if a file is currently open or locked, to make a tem-
porary copyof the file before allowing CrystalReports to open it. Note that this feature is disabled bydefault as it can affect per-
formance.

Use of 7-Zip has been denied by your Administrator
If you receive aWindows10message, which reads: Use of "7-Zip" hasbeen denied by your Administrator...
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This is a dependency / prerequisite built-in open source program that our application bundlesand uses for processing the following
document / source file types:

• Excel (xslx)

• MSWord (docx)

• SAPDashboards ( aka Xcelsius )

Aswell as if you have "Include Archives" checked off under the Local File System location and you have one or more archives in your
search folders.

If a system administrator enforcesa rule disallowing use of the 7-zip program, then either this restriction has to be removed by the sys
admin OR the end-user cannot search those particular document typeswith Find it EZ unfortunately. Note that the end-user may
even get thismessage when attempting to install Find it EZ. Theywill still be able to install the program, but use of the features requir-
ing 7-zip will record an error andmaycause the program to crash.

Find text in a text box in a Crystal Report
Searching of text field content is not enabled bydefault but can be enabled bydoing the following:

1. Close theSearch Wizard if you are using it (click on theCancel or X button).

2. On theSource panel (on the left), click on "CrystalReports." Thiswill bring up theProject Settings for CrystalReports.
Alternatively, you can get to thiswindow from themenu as follows: Projects -> Settings, then click on "CrystalReports."
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3. Click to check the Text Field Content option.
4. Click on theClose button.
5. The next time a search is done it should look through the text box content for you.

List of VSS folders slow to load
When configuring a VisualSource Safe in particular, retrieving a list of folders to search within a selected branch can take a long time
to load. This can also be the case with other source code version control systems.

Solution:

Rather then using a native connection to the version control systemwithin Find it EZ project source settings, alternatively, you can
recursively pull a copyof a branch using the native version control system client to save a temporary copyof all folders and files to your
localworkstation where Find it EZ is installed. Then, configure searching the local copyof the documents rather then a connection to
the version control system source within your Find it EZ project. Thiswill eliminate the overhead and latencywith use of the vendor
connector API aswell as anypossible network bottleneckswhen retrieving remote folders and documents. The downside to this
alternative is that you would have to ensure you refresh your local copyof files asneeded. However, Find it EZ indexing / index
refresh will be dramatically improved using this two step approach.
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Find it EZ Support
This section describes themanysupport optionsavailable with Find it EZ, how to send feedback, report a bug, or a request a feature
to Find it EZ Software Corp., and to view or send your session log.

Support Options
Support Option Navigation

Contact Find it EZ Software Corp https://www.finditeztest.com/support/#contact

FrequentlyAskedQuestions https://www.finditeztest.com/support/#faq

Search Knowledge Base https://www.finditeztest.com/support/#kb

Syntaxand Examples https://www.finditez.com/support/#syntax

Request a Demo https://www.finditez.com/support/#demo

Watch InstructionalVideos https://www.finditez.com/resources/#by_video

View Session Log From the programmenu, select Tools -> View Session Log. The session log
will open in Notepad. Each event line will start with the event date and time, fol-
lowed bydetails.

Send Logs to Support From the programmenu, selectHelp -> Send Logs to Support

Check for Updates From the programmenu, selectHelp -> Check for Updates.

Report a Bug or Request a New Feature
From the program:

1. From the Find it EZ menu, selectHelp -> Report a Bug.
2. Fill in the form:

a. In theSummary text box, enter a brief but descriptive summaryof the issue.

b. In theDescription text box, enter a detailed description of the issue or request. For bugs, include detailed steps
required to reproduce the issue.

Tip: To send logs to Find it EZ Support,See"Find it EZ Support" above.

3. Click on theSubmit Bug button.

On the website:

See:"Create a Support Ticket" on page 175

https://www.finditeztest.com/support/#contact
https://www.finditeztest.com/support/#faq
https://www.finditeztest.com/support/#kb
https://www.finditez.com/support/#syntax
https://www.finditez.com/support/#demo
https://www.finditez.com/resources/#by_video
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My Find it EZ Account
This section describeshow to register for andmanage your Find it EZ account, access software downloads, andmanage serial num-
bers, quotes, orders, support tickets, and sending feedback.

My Account
TheMy Account tab on themember website allowsyou tomanage your contact information, update alerts, subscriptions, and
change your password. This section will describe how to register for and log in tomanage your Find it EZ account.

Once registered, you can log in to the securemember area of Find it EZ, where you can change your password, download product
updates, update your email subscriptions, retrieve product activation keys, view order history, processpayments, checkon the status
of or submit new support tickets.

Register for a free Find it EZmember account:
1. Visit https://www.finditez.com/register.

2. Fill in theNew User Registration form.

Note: Itemswith dots are required. TheAre you Human? optionmust also be checked.

3. Click on theRegister button. A verification emailwill be sent to the provided email address.
4. To complete your registration, click on the link in the email . The website will open and you will be logged in automatically.

Log In to Your Find it EZMember Account
To log in to your Find it EZ member account, follow these steps:

1. Visit https://www.finditez.com/login.
2. Enter your accountEmail Address andPassword.
3. Click on the Log In button. The securemember site will open with theMy Account tab selected.

Update Account Details and Preferences
1. On theMy Account tab, make changesasdesired.

2. Click on theUpdate button to save.

Change Account Password
1. On theMy Account tab, click on theChange Password button. AChange Password dialog boxwill appear.
2. Enter and confirm the new password.

3. Click on theUpdate button to save your changes.
4. Click on theX button to close theChange Password dialog box.

See Also:
• "Manage Linked User Accounts" on the next page

• "Manage CompanyAddressRecords" on the next page

https://www.finditez.com/register.aspx?Src=
https://www.finditez.com/login.aspx
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Manage Linked User Accounts
AddNewAccount Admin Contact

1. Log in to your Find it EZ Member Account. See: "MyAccount" on the previouspage

2. On theMy Account tab, scroll down to locate the Linked User Administration section.
3. In theUser column, click on theAdd more link. TheAdd New Contact dialog boxwill appear.

4. Enter information for the new contact.

Note: Youmust use a valid corporate email domain address. Free or blacklisted email domains (e.g. gmail, hotmail, etc.)
are not accepted.

5. Click on theAdd button to save. If a password wasnot entered, a temporary one will be sent to the new contact.

Alert: We highly recommend that the new contact logs in and changeshis/her temporary password as soon aspossible.

6. To add another contact, click on theAdd Another button and repeat steps4 and 5 above. Or, click on theClose or X but-
ton to exit.

Change Prime Account Contact
1. Log in to your Find it EZ Member Account. See: "MyAccount" on the previouspage

2. On theMy Account tab, scroll down to locate the Linked User Administration section.
3. In thePrime Contact column, click to choose the new prime/admin contact.

4. Click on theChange Prime Contact button to save your change.

Remove an Account Contact
1. Log in to your Find it EZ Member Account. See: "MyAccount" on the previouspage

2. On theMy Account tab, scroll down to locate the Linked User Administration section.
3. Locate the name of the contact you want to remove from your account.

4. In the far right column, click on the correspondingRemove link. A confirmationmessage will appear.
5. To remove the selected contact, click on theYes button. The contact will be removed from the list.

6. To cancel, click on theNo button.

Manage Company Address Records
Your companyaddress recordsare automatically added and/or updated during the order check-out process.
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In addition to being able to select, add, or update address recordsusing our secure cart check-out process, anyactive contact may
also add, update, or remove address records that are linked to the companyprofile. These changesare immediately reflected and
available for subsequent online orders placed.

AddCompany Address
1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. On theMy Account tab, scroll down to locate theAddress List section.
3. In theCompany Address column, click on theAdd more link. TheAddress Information dialog boxwill appear.

4. Enter or select company location information.

Note: Itemswith a dot are required.

5. Click on theSave button. The new addresswill be added to the list.

Update Company Address
1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. On theMy Account tab, scroll down to locate theAddress List section.
3. Locate the address you want to edit.

4. In the far right column, click on the corresponding edit icon. TheAddress Information dialog boxwill appear.

5. Change company location information asdesired.

Note: Itemswith a dot are required.

6. Click on theSave button.
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Remove Company Address
1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. On theMy Account tab, scroll down to locate theAddress List section.
3. Locate the address you want to delete.

4. In the far right column, click on the corresponding delete icon. A confirmationmessage will appear.

5. To delete the selected companyaddress, click on theYes button. The addresswill be removed from the list.

6. To cancel, click on theNo button.

See Also:
• "Manage Linked User Accounts" on page 164

Software Downloads
TheSoftware Downloads tab on themember website allowsyou to download new releasesand connectors and to view release
notesand system requirements.

Download Release Version
1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSoftware Downloads tab. A list of product releasesand optional connectorswill appear.

3. Locate the product and release version that you want to download.

4. In theVersion column, click on the product release number for the corresponding product row. The release will begin to
download.

5. Locate and launch the *.exe file. A Find it EZ InstallShield Wizard dialog boxwill appear.
6. Click on theNext button.
7. Read and follow the installation instructions.

8. When complete, click on the Finish button.

See Also:
• "Download Connectors" on the facing page

• "View Release Notes" below

• "View SystemRequirements" on the facing page

View Release Notes
From the Program:

1. From the Find it EZmenu, selectHelp -> View Release Notes.Release Noteswill open in a new browser window show-
ing themost recent information first.

2. Scroll down to view historical notes.

3. To closeRelease Notes, close the browser tab or window.

On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSoftware Downloads tab. A list of product releasesand optional connectorswill appear.
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3. Locate the product release for which you want to view release notes.

4. In theNotes column, click on the corresponding note icon. ARelease Notes dialog boxwill appear showing themost
recent information first.

5. Scroll down to view historical notes.

6. To close theRelease Notes dialog box, click on theX button.

View System Requirements
On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSoftware Downloads tab. A list of product releasesand optional connectorswill appear.
3. Locate the product release for which you want to view system requirements.

4. In theSpecs column, click on the corresponding download icon. ASystem Requirements dialog boxwill appear.

5. To download the selected product release, click on theDownload Nowbutton.

6. To close theSystem Requirements dialog box, click on theX button.

See Also:
• "Download Release Version" on the previouspage

Download .NET Framework
Alert: The .NET framework connector is required. If you do not have the required .NET 4.5 pre-installed, you will be prompted to
download this prerequisite fromMicrosoft. We provide an alert and link to the appropriate download page depending on theWin-
dowsoperating system you are running. The programwill not launch until .NET 4.5 is installed.

On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSoftware Downloads tab. A list of product releasesand optional connectorswill appear.
3. Locate the product release for which you want to download the .NET framework.

4. In the .net column, click on the corresponding .NET version number. AMicrosoft.NET Framework dialog boxwill appear.
5. To download the selected version from the Find it EZ server, click on theDownload Nowbutton. OR

6. To download the selected version directly fromMicrosoft, click on the directly from Microsoft link.

7. To close theMicrosoft.NET Framework dialog box, click on theClose or X button.

Download Connectors
Source items that require a connector will appear with a smallwarning icon preceding the name. See example below:

Note: Some connectors are required (e.g. '.net') but others are optional (depending on whether or not you want to search a par-
ticular document type that then needsa corresponding vendor supplied connector). After product install on first run configuration
wizard for setting up your environment, if you select one or more source items that require connectors, the wizard will prompt you
to auto-download and install them. If you do not do so, or later add a source item, you will note that it hasa yellow alert triangle icon
next to it in the left (Source) panel. If you attempt to include such a source item in a project, you will be prompted to auto download
and install the required connector.
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Click on the source item/warning to download the associated connector.

If you try to initiate a search that includesa selected source lacking a required connector, an error message will be generated. See
example below:

From the Program:

Note: Downloading and installing a connector will require local administrative rights on your system.

1. From the Find it EZ menu, select Tools -> Download Connectors -> [Connector Name]. ADownload Connector
dialog will appear.

2. Where applicable, click on theProxy Settings button. AProxy Settings dialog will appear.

a. Enter your proxy credentials for the selected connector.

Note: If you don't know your proxy credentials, please contact your network administrator.

b. When settingsare complete, click on theOK button to save.
3. Click on theDownload & Install button. The connector will begin downloading.

a. Once downloaded, a Find it EZ InstallShield Wizard will appear.
b. Click on theNext button.
c. Read and follow the instructionsprovided.

d. When complete, click on the Finish button.
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On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSoftware Downloads tab. A list of product releasesand optional connectorswill appear.
3. Locate the product release for which you want to download a connector.

4. In theDownload Optional Connectors section of the table, click on the corresponding version number in the desired con-
nector name column. AConnector Details dialog boxwill appear.

5. To download the selected version from the Find it EZ server, click on theDownload Nowbutton. OR,

6. Where applicable, to download the selected version directly fromMicrosoft (i.e. Access), click on the directly from
Microsoft link or directly from SAP (i.e. CrystalReports), click on the directly from SAP link.

7. The connector will begin downloading.

a. Once downloaded, a Find it EZ InstallShield Wizard will appear.
b. Click on the Next button.
c. Read and follow the instructionsprovided.

d. When complete, click on the Finish button.

8. To close theConnector Details dialog box, click on theClose or X button.

See Also:
• "SAPRepositories - Compatibility Table" below

SAP Repositories - Compatibility Table
Below is a compatibility table for SAP repositories:

BI 4.1

• BusinessObjectsBI platform 4.1

• BusinessObjectsBI platform 4.0

• CrystalReportsServer 2013

• CrystalReportsServer 2011

XI 3.1

• BusinessObjectsEnterprise XI 3.1

• BusinessObjectsEnterprise XI 3.0

• CrystalReportsServer 2008

Serial Numbers
TheSerial Numbers tab on themember website allowsyou tomanage or transfer your current Find it EZ product license, obtain a
new trial license, activate or manually activate a product, review software assurance plansand license type options.

Follow the stepsbelow to view your current Find it EZ product serial numbers.

On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSerial Numbers tab. A list of your product licenseswill appear.
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View or Transfer Current License
On the Website:

1. See "SerialNumbers" on the previouspage

2. Locate the product for which you want to view or transfer the current license.

3. Click on the correspondingDetails link. AView/Transfer License dialog boxwill appear.
4. To download themost recent upgrade, click on the [version upgrade] link.
5. To transfer the license to a newmachine, click on the Transfer to new machine link.
6. To close theView/Transfer License dialog box, click on theX button.

See Also:
• "Download Release Version" on page 166

• "Transfer to a NewMachine" below

• "Enter New SerialNumber" on the facing page

Transfer to a New Machine
From the Program:

1. From the Find it EZ menu, select Tools -> License Management -> Transfer to a new machine. A confirmationmes-
sage will appear, as below:

2. Click on theOK button to shut down Find it EZ on the current machine.

3. Open your e-mail and follow the instructions to transfer the license to a newmachine.

On the Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSerial Numbers tab.

3. Locate your active license in the list and click on the correspondingDetails link. AView/Transfer License dialog boxwill
appear.

4. Click on the Transfer to new Machine link. Our support staff will then automatically receive a transfer request to approve.
Once that hasbeen completed, you will receive an approval email and you can then re-use the license on the new work-
station.

See Also:
• "Download Release Version" on page 166.
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Enter New Serial Number
From the Program:

1. From the Find it EZ menu, select Tools -> License Management -> Enter a new serial number. TheActivate dialog
boxwill appear.

2. Fill in the required information.

Note: Input fieldswith an "*" are required.

3. Click on theActivate button.

See Also:
• "Activate License" on page 8

• "SerialNumbers" on page 169

Get a NewTrial License
On the Public Website:

1. Visit https://www.finditez.com/.
2. Click to select the desired product edition tab.

3. Click on theDownload Now! button.

On the Member Website:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click to select theSerial Numbers tab.
3. Click on theGet a New Trial License button. ARequest License dialog boxwill appear.
4. From the drop-down list, select the product for which you want to request a trial.

5. Click on theRequest License button. The trial license information will be sent to your account e-mail address.

6. Open your e-mail. Note the trial license serial number and click on theDownload Nowbutton.

See Also:
• "MyAccount" on page 163

• "Activate License" on page 8

• "Activate LicenseManually" on page 9

Purchase Licenses
1. See "SerialNumbers" on page 169

2. Locate the product edition for which you want to purchasemore licenses.

3. In theBuy More column, click on the corresponding shopping cart icon.
4. Enter the desiredQuantity.
5. In theAdd Software Assurance section, choose an assurance option.
6. Click on theAdd to Quote button. You will be directed to theQuote Summary page.
7. To addmore items, click on the + Add More Items button.
8. To edit or delete an item, click on the corresponding icon located to the right of each item.

https://www.finditez.com/
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9. Where applicable, enter a discount code and click on theApply Coupon button.
10. To send the quote to Find it EZ Software Corp, click on theSend Quote button.
11. To buy the selected product(s) now, click on theCheckout button.

**Note to Ken:Wondering if we should change the heading here to "Purchase Additional Licenses." Also, would you likeme to include
an "On the PublicWebsite" procedure and the above "On theMember Website" procedure... ?

Software Assurance Plans
There are two typesof licensesand correspondingmaintenance (software assurance) plans:

Code Search Pro (Desktop and Server)

• Perpetual licenses. First year software assurance included.

• After year 1, software assurance is optional. However, if you do not renew and want access to an upgrade (newer release
than the last one available when your software assurance lapsed), youmust buya new license. Upgrade discountsmaybe
considered at our discretion on a case by case basis.

DevSurge 365

• SaaS licenses. Software assurance included.

• Renewal ismandatory for use of the software. Otherwise, once your subscription expires, the software stopsworking.

What Software Assurance includes:

• Unlimited support incidents. Direct access to our support (development) team via phone,WebEx, remote desktop, email,
etc.

• Ability to request a license transfer (approval only possible if on an active software assurance plan). This can be required if
on change of employee or reconfiguration / major upgrade of the workstation (e.g. newer operating system, change of work-
station name on the companydomain, major hardware upgrade such ashard drive, etc.).

• Access to new software release upgrades.

Software assurance is typically quoted / invoiced for a one year period. During payment remittance, you can choose to take advant-
age of extending your software assurance period to:

• Save 5%for 2 year; 10%for 3 year plans.

• Enjoy the convenience of only have to renew every 2 or 3 years instead of annually.

• Coordinate with a POprocess to reduce overhead and approval requirements.

• Take advantage of available surplus budget when possible.

For more information about our software assurance plans:

• Visit https://www.finditez.com/cart/ and click on theSupport and Upgrades or the License Information links at the
top of theProduct Catalog page for more detail and definitions.

• Click on anySelect Options button for a product line item. Note that you can get a discount on extending your pre-paid sup-
port plan. Click to expand theSoftware Assurance tab.

Annual Renewals
Annual renewal noticesare sent as follows for existing customers:

If, on the final payments remittance page, you chose to "auto-renew," then you will be invoiced and will receive this invoice 45 days
prior to your software assurance plan expiry date. If payment is not remitted, reminders are auto-sent 3 weeks ( 21 days ) and again
3 daysprior to support expiry. If payment is still not received, an overdue notice is sent 5 daysafter support expiry and collection
actionmaycommence.

https://www.finditez.com/cart/
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If you do not check the "auto-renew" setting, then you will simply receive a renewal quote 3months ( 90 days ) prior to your software
assurance plan expiry date. Reminders are sent 21 daysand 3 daysprior to support expiry.

If payment is not received after your software assurance plan expiry date, this lapse effect does the following:

• Code Search Pro: Keepsworking, but no support responsesand can no longer transfer the licenses. Themember down-
loadspanel changes to add a section for "older versions" so that you have access to download themaxversion you are eli-
gible to use.

• Dev Surge 365: Stopsworking.

License TypeOptions
For further information about licensing, please contact support@finditez.com.

License types for Find it EZ products

Find it EZ products are either sold or leased under two distinct license plans:

• Perpetual - Permanent right to use license is purchased. First year software assurance is included with access to allminor
andmajor upgrades for free. Optional software assurance.

• Software As A Service (SaaS) - Annual renewable contract lease plan. If your contract is not renewed, the product can
no longer be used and all licensesare automatically disabled upon expiry of the contract term.

Under either plan, there are also two available end-user license types to chose from:

• Name User Licenses (NULs) - Each license is associated with a single, unique windowsuser login and host machine com-
bination. NULsare transferable betweenmachinesand/or users but must go through an automated transfer request,
vendor review and approval processat the sole discretion of Find it EZ.

• Concurrent Access Licenses (CALs) - Each license is associated with aWindowshost machine, but floating amongst all
domain users. Also commonly known as floating licenses. Only limited in use to themaximum number of concurrent con-
nection (licenses) purchased.

Alert: For further information about licensing, please contact support@finditez.com.

Note: DevSurge 365 Enterprise is only available in on-premiseSoftware As A Service - Named User Licenses.

See Also:
• "License Agreements and Statements" on page 177

Quotes
Aquote is a 15 dayprice guarantee with no obligation to payby the customer. TheQuotes tab on themember website allowsyou to
compare products, create and view quotes, and pay for a quote.

Create a NewQuote
1. Visit https://www.finditez.com/.
2. From themenu at the top of the page, selectQuotes -> New Quote. TheProducts Catalog will appear.
3. Locate the product that you want to add to a quote.

4. Click on the correspondingAdd to Quote button. AQuote Summary page will appear.
5. To addmore items, click on the + Add More Items button.
6. To edit or delete an item, click on the corresponding icon located to the right of each item.

mailto:support@finditez.com?subject=Licensing Inquiry
mailto:support@finditez.com
https://www.finditez.com/


View SavedQuotes

174 © 2010 - 2016 Find it EZ Software Corp

7. Where applicable, enter a discount code and click on theApply Coupon button.
8. To send the quote to Find it EZ Software Corp, click on theSend Quote button.

ViewSavedQuotes
1. "Log In to Your Find it EZ Member Account" on page 163.

2. From themenu at the top of the page, selectQuotes -> My Saved Quotes. A table will appear showing the quoteOrder
#,Expiry Date,Amount, andStatus.

3. To edit the quote, click on the correspondingEdit icon.
a. Make changesasdesired.

b. Click on theUpdate Quote button to save and send to Find it EZ Software Corp.
4. To download the quote in PDF file format, click on the correspondingPDF icon.

a. The quote will open asa PDF in a new browser window.

b. Download or Print the document asdesired.

Pay for a Quote
1. See "View SavedQuotes" above.

2. Locate the quote for which you want to pay.

3. In thePay Now column, click on the corresponding shopping cart icon. TheCheckout dialog boxwill appear.
4. Select theBilling andShipping Address, then click on theSave and Continue button.
5. Review and confirm the order, then click on theSave and Continue button.
6. Select and enter themethod of payment.

7. Click on theProcess Payment button.

See Also: 
• "Find it EZ Product Editions" on page 1

Orders
An order generatesa net 30 day invoice. Or, if the customer proceeds through secure check-out and remits payment online (via pur-
chase order, credit card, or Paypal account), a receipt is issued along with immediately releasing activation keys. TheOrders tab on
themember website allowsyou to create and view orders.

ViewMyOrders
1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click on theOrders tab. All current orders on file will be listed.

Create a NewOrder
1. Click on theCreate New Order button. TheProducts Catalog will appear.
2. Locate the product(s) you want to add to your order.

3. To select a product, click on theAdd to Cart button. Go to step 6.



MySupport Tickets

© 2010 - 2016 Find it EZ Software Corp 175

4. To select product options, click on the correspondingSelect Options button.
a. Enter the desiredQuantity.
b. Choose the desiredSoftware Assurance plan.
c. Click on theAdd to Cart button.

5. To addmore items, click on the + Add More Items button.
6. To edit or delete an item, click on the corresponding icon located to the right of each item.

7. Where applicable, enter a discount code and click on theApply Coupon button.

8. To save the order asa quote, click on theSave as quote button.

9. To pay for the order, click on theCheckout button.

My Support Tickets
TheMy Support Tickets tab on themember website allowsyou to create, attach a file to, send, and view your support tickets.

Create a Support Ticket
To create a support ticket:

1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click on theMy Support Tickets tab.
3. Click on theCreate a Support Ticket button. ATicket Systemdialog boxwill appear.

4. In theProduct Information section:
a. Select the affected product name from theProduct drop-down list.
b. Select the affected version from theVersion Found drop-down list.

5. In theProblem Description section:

a. Select the appropriate issue severity from theSeverity drop-down list. Refer to the image below:

b. In theSummary text box, enter a brief and descriptive summaryof the issue or problem.
c. In theDescription text box, enter a detailed description of the issue or problem.
d. In theSteps to Reproduce text box, thoroughly describe the steps required to reproduce the issue or problem.

Include asmuch detail as possible.

6. To attach a file to the support ticket:

a. Click on theChoose File button.
b. Navigate to the file you want to attach.

c. Click on theOpen button. The file namewill appear in the File Attachment section to the right of theChoose File
button.

7. To send the support ticket to Find it EZ support, click on theSend Report button.
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ViewMy Support Tickets
1. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

2. Click on theMy Support Tickets tab. A list of your submitted support ticketswill appear showing the Issue #,Reported
date/time,Status, Last Updated date/time, andSummary.

Note: It may take up to 24 hours for new issues to appear in this list.

See Also:
• "Find it EZ Support" on page 162

• "Send Feedback" below

Send Feedback
To provide feedback to Find it EZ Software Corp., follow these steps:

1. From the program:

a. From the Find it EZ menu, selectHelp - Send Feedback. You will be directed to the Find it EZ website.

b. To log in to the Find it EZ member site, enter your account e-mail addressand password and click on the Login but-
ton or press the [Enter] keyon your keyboard. Themember site will appear with the Feedback tab selected.

2. On the website:

a. Log in to your Find it EZ Member Account. See: "MyAccount" on page 163

b. Click on the Feedback tab.

3. Enter or confirm your companyand/or personal information on the form.

Note: Itemswith dots are required. Abbreviations can be used for anonymity.

4. Enter your feedback into theComments text box (max. 250 characters).
5. If more space is needed, enter more feedback into theMore Space Needed? text box.
6. Click on theSend Feedback button. A confirmationmessage will appear to confirm your feedbackhasbeen sent.

See Also:
• "MyAccount" on page 163

• "Create a Support Ticket" on the previouspage

• "Find it EZ Support" on page 162
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License Agreements and Statements
Visit https://www.finditez.com/support/documents/eula.pdf to view the Find it EZ Software Corp Software License Agree-
ment.

https://www.finditez.com/support/documents/eula.pdf
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